InContent Prefs - Don't allow text selection of categories

VERIFIED FIXED in Firefox 38

Status

()

Firefox
Preferences
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Stanzilla, Assigned: gioyik, Mentored)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 39
Points:
---

Firefox Tracking Flags

(firefox38 verified, firefox39 verified)

Details

(Whiteboard: [lang=css][good first bug])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2305.3 Safari/537.36

Steps to reproduce:

Can you make it so that selecting a menu item does not cause a typing indicator[1] to appear? I also think it would feeld more "native" if you cannot select the text of the menu item.[2]

[1]: http://i.imgur.com/J2SRH1p.png
[2]: http://i.imgur.com/pJYXEg1.png
(Reporter)

Updated

3 years ago
Blocks: 1014208
Component: Untriaged → Preferences
OS: Windows 8.1 → All
Hardware: x86 → All
See Also: → bug 1014208
Version: Trunk → unspecified
(Reporter)

Comment 1

3 years ago
I actually just noticed that it does the typing indicator for all button elements, too. See http://i.imgur.com/s0bRCv2.gif

Comment 2

3 years ago
(In reply to Stanzilla from comment #1)
> I actually just noticed that it does the typing indicator for all button
> elements, too. See http://i.imgur.com/s0bRCv2.gif

This focus ring only appears when you start using the keyboard to navigate the UI, once you've done so, the focus ring reappears when you click. You get the same behavior in some parts of Windows. That focus ring is for accessibility too, so I suspect we'll ever remove that. 

I agree we should remove text selection from the category labels though (it is also consistent with the add-on manager). Let's use this bug for that.
Mentor: ntim007@yahoo.it
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [lang=css][good first bug]

Comment 3

3 years ago
To fix this bug :
- Add -moz-user-select: none; to :
http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/shared/in-content/common.inc.css#545

Updated

3 years ago
Summary: [chameleon] alter menu items style → InContent Prefs - Don't allow text selection of categories

Comment 4

3 years ago
(In reply to Tim Nguyen [:ntim] from comment #2)
> (In reply to Stanzilla from comment #1)
> > I actually just noticed that it does the typing indicator for all button
> > elements, too. See http://i.imgur.com/s0bRCv2.gif
> 
> This focus ring only appears when you start using the keyboard to navigate
> the UI, once you've done so, the focus ring reappears when you click. You
> get the same behavior in some parts of Windows. That focus ring is for
> accessibility too, so I suspect we'll ever remove that. 
Oh wait, I see you meant the text typing indicator (the gif didn't run for me at first).
For some reason, I can't seem to reproduce this.
(Assignee)

Comment 5

3 years ago
Created attachment 8567718 [details] [diff] [review]
1135508.patch
Attachment #8567718 - Flags: review?(ntim007)

Updated

3 years ago
Assignee: nobody → gioyik
Status: NEW → ASSIGNED

Comment 6

3 years ago
Comment on attachment 8567718 [details] [diff] [review]
1135508.patch

Thanks for the patch !

The patch looks good, but there seems to be some unrelated changes in it.
Btw, can you ask :jaws for the next review ? My review is worth nothing :)

Updated

3 years ago
Attachment #8567718 - Flags: review?(ntim007)
(Assignee)

Comment 7

3 years ago
Hi Tim,

You are right the patches get mixed, sorry for that. I am going to attach a new one fixed.

Thank you
(Assignee)

Comment 8

3 years ago
Created attachment 8567722 [details] [diff] [review]
1135508.patch

Patch fixed!
Attachment #8567718 - Attachment is obsolete: true
Attachment #8567722 - Flags: review?(jaws)
We should probably apply this to category headers too, but the rest of the UI (like the checkboxes, radio buttons, etc. should remain selectable).
Attachment #8567722 - Flags: review?(jaws) → feedback+
(Assignee)

Comment 10

3 years ago
Those headers?:

http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/shared/in-content/common.inc.css#560
http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/shared/in-content/common.inc.css#567
Flags: needinfo?(jaws)
(In reply to Giovanny Gongora [:gioyik] from comment #10)

Just http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/shared/in-content/common.inc.css#567
Flags: needinfo?(jaws)
(Assignee)

Comment 12

3 years ago
Created attachment 8568394 [details] [diff] [review]
1135508.patch

Patch v2
Attachment #8567722 - Attachment is obsolete: true
Attachment #8568394 - Flags: review?(jaws)
Attachment #8568394 - Flags: review?(jaws) → review+
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/32c84f014b3b
Keywords: checkin-needed
Whiteboard: [lang=css][good first bug] → [lang=css][good first bug][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/32c84f014b3b
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Whiteboard: [lang=css][good first bug][fixed-in-fx-team] → [lang=css][good first bug]
Target Milestone: --- → Firefox 39
(Reporter)

Comment 15

3 years ago
(In reply to Tim Nguyen [:ntim] from comment #2)
> (In reply to Stanzilla from comment #1)
> > I actually just noticed that it does the typing indicator for all button
> > elements, too. See http://i.imgur.com/s0bRCv2.gif
> 
> This focus ring only appears when you start using the keyboard to navigate
> the UI, once you've done so, the focus ring reappears when you click. You
> get the same behavior in some parts of Windows. That focus ring is for
> accessibility too, so I suspect we'll ever remove that. 
> 
> I agree we should remove text selection from the category labels though (it
> is also consistent with the add-on manager). Let's use this bug for that.

I uploaded the gif in a better resolution: https://dl.dropboxusercontent.com/s/5xaudrhnbdutb6o/2015-02-22_17-20-03.mp4?dl=0

I didn't use the keyboard for anything, I just clicked the button and the typing indicator appeared and started blinking as if you could write something into the button. That is not accessability thing.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 16

3 years ago
Maybe you inadvertently turned on Caret browsing? Press F7 to disable it.

Comment 17

3 years ago
(In reply to henryfhchan from comment #16)
> Maybe you inadvertently turned on Caret browsing? Press F7 to disable it.

Stanzilla, I think that might be the issue on your side. I've been able to reproduce this only with Caret Browsing Enabled.
Flags: needinfo?(staneck)
(In reply to henryfhchan from comment #16)
> Maybe you inadvertently turned on Caret browsing? Press F7 to disable it.

Yes, and you may want to see bug 993361 which is about the Caret being placed in the wrong position on XUL documents (such as the one in your video).
(Reporter)

Comment 19

3 years ago
Oh. Indeed. I never heard the term Caret browsing before and I probably toggled it by accident. There is no indicator in the UI if it is currently enabled, right? Anyway, this bug can be closed.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(staneck)
Resolution: --- → WORKSFORME

Updated

3 years ago
Resolution: WORKSFORME → FIXED
Duplicate of this bug: 1020285
Comment on attachment 8568394 [details] [diff] [review]
1135508.patch

Approval Request Comment
[Feature/regressing bug #]: new feature, in-content prefs (icp)
[User impact if declined]: users will be able to highlight category names in the prefs in 38 but not in 39. we want to uplift all icp patches to firefox 38 so that the first release of the feature is solid.
[Describe test coverage new/current, TreeHerder]: landed on mozilla-central for some time now.
[Risks and why]: none expected.
[String/UUID change made/needed]: none.
Attachment #8568394 - Flags: approval-mozilla-aurora?
status-firefox38: --- → affected
Attachment #8568394 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/e8f8a378c098
status-firefox38: affected → fixed
QA Contact: camelia.badau
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.9.5 using Firefox 38 Beta 6 (buildID: 20150420134330) and latest Aurora 39.0a2 (buildID: 20150424004008).
Status: RESOLVED → VERIFIED
status-firefox38: fixed → verified
status-firefox39: fixed → verified
You need to log in before you can comment on or make changes to this bug.