[RR][ABS POS]<a> with <span> with absolute positioning loses its style after the first time a mouse in over it.

RESOLVED DUPLICATE of bug 88154

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 88154
17 years ago
16 years ago

People

(Reporter: Alexey N. Solofnenko, Assigned: dbaron)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CSS1-5.4.3])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
0.9.6
Also: 
  in <span> the mouse pointer is wrong,
  and for unknown reasons <span> is positioned on the next line
Example page:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">
<html>
<body>
<table width="700">
  <tr><th>Row select test</th></tr>
  <tr><td><a href=".">Line1<span style="position: absolute; left: 200px;">The
first description</span></a></td></tr>
  <tr><td><a href=".">Line2<span style="position: absolute; left: 200px;">The
second</span></a></td></tr>
</table>
</body>
</html>

Comment 1

17 years ago
Created attachment 60468 [details]
Reporter's HTML code
Yech.  That's a pretty broken set of style rules (what _is_ the expected
behavior for text-decoration when you have block children of inlines, which is
invalid anyway?).

I suspect that we should never be drawing the underline on the positioned span,
and that this is a dup of bug 1777
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 3

17 years ago
But there are some other interesting layout issues here with parenting of style
contexts.  The positioning issue depends on interpretation of the CSS spec.

The bug reporter's original title, which should have been in the comment as
well, is (in case it gets changed):
"<a> with <span> with absolute positioning loses its style after the first time
a mouse in over it."
which is a problem that I actually don't see -- it doesn't lose its style for me
until I try to select it.

Comment 4

17 years ago
Whoa! I got a three-way mid-air collision trying to add these comments, so here
we go again...

I see this too, win98SE, 2001112903

Steps to reproduce :

1. Load the sample HTML file attachement (above), observe positioning of
descriptions: I'll leave the CSS experts to igure out what this SHOULD do.
2. mouse over the links on the left, observe "link select" cursor.  
3. mouse over the descriptions, observe "text select" cursor.
4. force a window re-paint, e.g. by maximising the window, observe the
descriptions are now black and not underlined.

Adding "testcase" keyword
Keywords: testcase
OS: All → Windows XP
Hardware: All → PC
(Assignee)

Updated

17 years ago
OS: Windows XP → All
Hardware: PC → All
By vertically resizing the window, I can also see the style getting lost.
Whiteboard: [CSS1-5.4.3]
(Assignee)

Updated

16 years ago
Summary: <a> with <span> with absolute positioning loses its style after the first time a mouse in over it. → [RR]<a> with <span> with absolute positioning loses its style after the first time a mouse in over it.
(Assignee)

Updated

16 years ago
Summary: [RR]<a> with <span> with absolute positioning loses its style after the first time a mouse in over it. → [RR][ABS POS]<a> with <span> with absolute positioning loses its style after the first time a mouse in over it.
(Assignee)

Comment 6

16 years ago
I have a fix for this.

*** This bug has been marked as a duplicate of 88154 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.