[WebIDE] Setting Breakpoints in Gaia::System app won't work in WebIDE

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
5 months ago

People

(Reporter: gweng, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

STR:

1. Set breakpoints in JS files in Gaia::System app
2. Do something that would trigger the code
3. Watch it if the IDE stopped at the breakpoint

Expect:

The IDE shows the line stopped and the stack.

Actual:

The IDE doesn't stop. There is nothing affected by the breakpoints.

---

I encountered this bug when I'm debugging Gaia::System app. In my recollection, this works well at v2.1 with AppManager. However, with the current Firefox & FirefoxOS, this is broken. I didn't test it with other apps.

---

Tested with:

Firefox: 35.0
FirefoxNightly: 38.0a1
FirefoxOS (Flame):

Gaia-Rev        a6881205deae450757a8d1e1ed65e5e5be0ec633
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/86d2bb8bb1c9
Build-ID        20150223010224
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  65
FW-Date         Mon Dec 15 18:51:29 CST 2014
Bootloader      L1TC000118D0
(Reporter)

Comment 1

4 years ago
NI the owner of the module since apparently no one noticed this issue so far.
Flags: needinfo?(dcamp)
Can you precise which precise breakpoint your are setting?
I tried multiple times since you reported this issue and wasn't able to reproduce.

For example, if I set a breakpoint in settings_core.js, around line 126, within settingsChanged closure,
I get the breakpoint correctly hit when I open settings app and toggle off and on the geolocation setting.
(Reporter)

Comment 3

4 years ago
OK thanks your reply. After upgraded my browser and re-check it again, the bug no longer exists.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(dcamp)
Resolution: --- → WORKSFORME

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.