[Messages] Can't autocomplete email recipients

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: julienw, Assigned: julienw, Mentored)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [sms-papercuts][lang=js])

Attachments

(1 attachment)

Assignee

Description

4 years ago
STR:
1. have 1 contact with only an email, no phone number
2. in the Messages app, tap "new message" button
3. write letters until the aforementioned contact is the first one in the suggestions list.
4. press "enter"

Expected:
=> the aforementioned contact should be added to the recipients list.

Actual:
=> it's not added. Instead, either the next contact that has a phone number is added, or no contact is added if there is none, leaving an invalid recipient.
Assignee

Updated

4 years ago
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
This issue only reproduces in 2.2 and master branches as the "Send MMS to e-mail addresses" feature was landed in 2.2.

Just adding that the recipient (contact with only e-mail addres) is added correctly if user presses on it in the suggested listed but not if the contact is the first one in the suggested list and user presses "enter" key. 
As Julien explains, we should be coherent and offer the same functionality than when a contact has a phone number.
Triage: Missing use case of a new functionality.
blocking-b2g: 2.2? → 2.2+
Assignee

Updated

4 years ago
Assignee: nobody → felash
Assignee

Updated

4 years ago
Status: NEW → ASSIGNED
Assignee

Comment 4

4 years ago
Comment on attachment 8569856 [details] [review]
[gaia] julienw:1135649-autocomplete-email-recipients > mozilla-b2g:master

Hey Oleg, what do you think of this?

The issue is that "Utils.isEmailAddress" is not the correct thing to use here, because fValue can be a name, or even the start of an email address. Instead I iterate all values (tels + emails).

There is remaining issue that we'll handle in bug 1084184: if we enter an email that matches a contact that also has phone numbers, and we press enter, the first displayed entry is taken.

I think this is still understandable because it's the first displayed entry, but this is misleading. Note that the same happens when a contact has 2 phone numbers, which is bug 1084184, that's why I suggest that we handle both cases in that bug.

Tell me what you think !
Attachment #8569856 - Flags: review?(azasypkin)
Assignee

Comment 5

4 years ago
Mmm I think I miss a unit test, I'll add one tomorrow, but you can still give me a first feedback if you want.
Assignee

Comment 6

4 years ago
New test added, you can review :)
Comment on attachment 8569856 [details] [review]
[gaia] julienw:1135649-autocomplete-email-recipients > mozilla-b2g:master

Looks good, thanks!
Attachment #8569856 - Flags: review?(azasypkin) → review+
Assignee

Comment 8

4 years ago
Fixed nits and landed:

master: 6f6c7645e3b63368e0c5f0c832cc72fb7df71342
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Updated

4 years ago
Blocks: mms-by-email
Assignee

Comment 9

4 years ago
Comment on attachment 8569856 [details] [review]
[gaia] julienw:1135649-autocomplete-email-recipients > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): new feature introduced in bug 974867
[User impact] if declined: incorrect behavior when looking for an email and pressing enter
[Testing completed]: yes, manually and unit tests
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8569856 - Flags: approval-gaia-v2.2?
Attachment #8569856 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed for the latest Nightly 3.0 and 2.2 builds.

Actual Results:  Adding a contact with only an email address by name works as expected in the mms app.
	
Environmental Variables:
Device: Flame 3.0 KK (319 MB) (Full Flash)
BuildID: 20150304010324
Gaia: 3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gecko: c5b90c003be8
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (319 MB) (Full Flash)
BuildID: 20150304002529
Gaia: 8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gecko: 2cb52b7cda5a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.