Closed Bug 1135675 Opened 10 years ago Closed 6 years ago

Tracking protection breaks video playback on bnn.ca and ctv.ca (g-a breakage)

Categories

(Firefox :: Protections UI, defect, P3)

x86
macOS
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: lmandel, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: tp-needsrepro)

As originally reported in webcompat.com (https://github.com/webcompat/web-bugs/issues/683), tracking protection breaks video playback on bnn.ca and ctv.ca.

STR:
1. Enable tracking protection (privact.trackingprotection.enabled=true)
2. Open http://www.bnn.ca/Video/player.aspx?vid=543904. (ctv.ca has the same problem but is now behind a pay wall.)

Expected:
Video player should load and play video.

Actual:
Video player doesn't load.
Summary: Tracking protection breaks video playback on bnn.ca and ctv.ca → Tracking protection breaks video playback on bnn.ca and ctv.ca (g-a breakage)
The resource at "http://cdn.krxd.net/controltag?confid=InSaVlLc" was blocked because tracking protection is enabled. player.aspx
The resource at "http://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-50ec42877c97615a" was blocked because tracking protection is enabled. player.aspx
The resource at "http://www.googletagservices.com/tag/js/gpt.js" was blocked because tracking protection is enabled. player.aspx
The resource at "http://b.scorecardresearch.com/beacon.js" was blocked because tracking protection is enabled. player.aspx
The resource at "http://www.google-analytics.com/ga.js" was blocked because tracking protection is enabled. player.aspx
The resource at "https://s0.2mdn.net/instream/html5/ima3.js" was blocked because tracking protection is enabled. player.aspx
The resource at "http://b.scorecardresearch.com/b?c1=2&c2=3005664&rn=0.9238550010428143&c7=http%3A%2F%2Fwww.bnn.ca%2FVideo%2Fplayer.aspx%3Fvid%3D543904&c3=&c4=&c5=&c6=&c10=&c15=&c16=&c8=BNN%20-%20Watch%20TV%20Online%20%7C%20YMM%3A%20Debt%20or%20RRSP%3F&c9=&cv=1.8" was blocked because tracking protection is enabled. player.aspx
The resource at "http://js-agent.newrelic.com/nr-632.min.js" was blocked because tracking protection is enabled.
Component: DOM: Security → Safe Browsing
Product: Core → Toolkit
Component: Safe Browsing → Tracking Protection
Product: Toolkit → Firefox
Confirming this issue still exists on bnn.ca.
Blocks: tpvideo
No longer blocks: tp-breakage
Keywords: DevAdvocacy
Priority: -- → P5
Whiteboard: tp-base
Component: Tracking Protection → Desktop
Keywords: DevAdvocacy
Priority: P5 → --
Product: Firefox → Tech Evangelism
Tested on 58.0a1 with TP enabled. Videos remain blocked. Original link is now a 404, tested:

http://www.bnn.ca/video/boc-decision-welcome-as-housing-markets-catch-up-to-changes-royal-lepage~1241630
Priority: -- → P5
Component: Desktop → Tracking Protection
Priority: P5 → P3
Product: Tech Evangelism → Firefox
Whiteboard: tp-base → tp-needsrepro
I am no longer able to reproduce this issue.
http://prntscr.com/k8uc7m

I have used this link: https://www.bnnbloomberg.ca/they-don-t-want-my-help-harper-blasts-trudeau-s-nafta-strategy-1.1111411

Tested on MacOS 10.13.5 and Windows 10, on Nightly 63, with Strict Tracking Protection enabled.

Lawrence, is this still an issue on your side?
Flags: needinfo?(rbillings)
Tested on Nightly 63 with Strict TP. The original link is now a 404, but was able to see/play video using link from comment 4.
Flags: needinfo?(rbillings)
Closing as fixed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.