Mozilla doesn't load page

RESOLVED DUPLICATE of bug 111752

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 111752
17 years ago
17 years ago

People

(Reporter: Schelstraete Bart, Assigned: jst)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [NT]
BuildID:    20001120303

If you press 'vertalen' (=translate)
Mozilla keeps loading, without showing anything.
This page works in Netscape 4.x / IE.

Reproducible: Always
Steps to Reproduce:
1. Surf to http://www.euroglotonline.nl/
2. Enter a word into the field 'woord'
3. Press 'vertalen'

Actual Results:  Mozilla loads page, but that one is empty (yellow background)
-> Form submission
and confirming with win2k build 20011204..
Assignee: morse → alexsavulov
Status: UNCONFIRMED → NEW
Component: Form Manager → Form Submission
Ever confirmed: true
QA Contact: tpreston → vladimire

Comment 2

17 years ago
Seems to be JavaScript/cookie issue because page contains JavaScript that should
send a cookie, but I don't receive any cookie alert (I set Mozilla to alert me
whenever a site tries to set a cookie). This is with build 2001120303 on Win2k.

Comment 3

17 years ago
-> Cookies.
Assignee: alexsavulov → morse
Component: Form Submission → Cookies
QA Contact: vladimire → tever

Comment 4

17 years ago
It's a javascript error alright -- never even gets to setting the cookie.  If 
you look at the js console you'll see the message:

   Error: popupWin.focus is not a function
   Source File:    http://www.euroglotonline.nl/Line: 90

Not sure if its a problem in our js engine or in the user's content.  
Reassigning to js component so that they can make the determine which it is.
Assignee: morse → rogerl
Component: Cookies → Javascript Engine
QA Contact: tever → pschwartau

Comment 5

17 years ago
Line 90 is indicated below. Reassigning to DOM Level 0. I do not know
if popupWin.focus is supposed to be a valid function or not - 

//Basic stuff to submit form
function openWin ()
{
var theword = document.forms[0].srcInput.value;
if (theword == "" || theword == " ")
{alert("Tik een woord in om te vertalen");
document.forms[0].srcInput.focus();
return false;
}
var egsrclang = 
document.forms[0].srclang.options[document.forms[0].srclang.selectedIndex].value
;
var egdstlang = 
document.forms[0].dstlang.options[document.forms[0].dstlang.selectedIndex].value
;
var egmorphreg = document.forms[0].morphreg.checked;

//alert("egmorphreg= "+egmorphreg);

//var URL = 
("/cgi-bin/Eginternet/Euroglot.exe?ScreenLanguage=Dutch"+"&srcLang="+egsrclang+"
&dstLang="+egdstlang+"&srcInput="+theword+"&MorphReg="+egmorphreg+"&");
var URL = 
("/scripts/Eginternet/Euroglot.exe?&ScreenLanguage=Dutch"+"&srcLang="+egsrclang+
"&dstLang="+egdstlang+"&srcInput="+theword+"&MorphReg="+egmorphreg+"&");  
//MorphReg=TRUE -> stond keihard in string
if (!is_nav)
{
popupWin=window.document.open (URL, 'egonline', 'width=663, height=464, 
scrollBars=1, top=122, left=172, toolbar=0, location=0, directories=0, status=1, 
menuBar=0, resizable=0');
popupWin.focus();
}
else
{
popupWin=window.document.open(URL, 'egonline', 
'width=663,height=464,scrollbars=yes,top=122,left=172');

popupWin.focus();  <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< LINE 90
}
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → amar
Summary: Mozilla doesn't load page's → Mozilla doesn't load page

Comment 6

17 years ago
It probably won't work at the moment, because document.focus() doesn't exist,
although the fix for bug 111752 will probably fix it.
(Assignee)

Comment 7

17 years ago
Yup, bug 111752 will fix this.

*** This bug has been marked as a duplicate of 111752 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.