Closed Bug 113574 Opened 18 years ago Closed 13 years ago

Add site icons (favicons) to sidebar, manage bookmarks, and history

Categories

(SeaMonkey :: Bookmarks & History, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED WORKSFORME
mozilla1.4alpha

People

(Reporter: mozilla, Assigned: janv)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file, 3 obsolete files)

<sigh>  Well, with Blake's conversion to <outliner> which just landed, it looks 
like favicons and branded search result icons in bookmarks (management window and 
sidebar) are now broken.

Thoughts on how to fix?
probably seeing this on linux, 2001120506.
(bookmarks sidebar is pretty useless, have to doubleclick on the bookmarks to
open them and then they come in a new window, no icons at all)
os -> all?
*** Bug 113960 has been marked as a duplicate of this bug. ***
*** Bug 114317 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
OS: Mac System 9.x → All
Target Milestone: --- → mozilla0.9.7
They work for me, but at least some of them seam to be forgotten on restart.
The icons appear to be getting lost at restart, but I believe that is different
than this defect. In this case the favicon is being used in Tabs and in the
personal toolbar but are not being reflected in the Sidebar Bookmarks window.

Created attachment illustrating lost icon.
Target Milestone: mozilla0.9.7 → mozilla0.9.8
Blocks: 113510
No longer blocks: 113510
I can verify the problem with the lost icons under windows 2000.

But they don't get lost every restart (of browser or windows), but only after
some days.
Also sometimes not all icons are gone but only some of them.

Maybe icons get lost after some days of not visiting the site?
Frequently visited sites seem to hold their icons.
With 0.9.7 on RedHat Linux 7.2 I always lose favicons on restart (even though
bookmarks.html has them) and I never see them in sidebar.
Target Milestone: mozilla0.9.8 → mozilla0.9.9
Not sure if this is the same problem, but I see favicon lossage *randomly*,
restart or no.  I haven't been able to build a test case.
I lose all favicons on new window creation. Well, in the personal toolbar at
least, usually don't check with the menu, but there sure as heck aren't any
favicons there now (:
It seems there is still come confusion between several favicon bugs. The way I
understand it, we have (at least) 3 different bugs.

Bug 109959 deals with favicon in the *url bar*. The problem usually manifests in
favicon disappearing on *page reload* and sometimes not appearing when already
visited page is revisited.

Bug 113574 deals with favicons in bookmarks *sidebar and management window*. For
some people (including myself), favicons *no longer appear there at all, no
matter what we do*. According to the initial reporter, this may be caused by
"conversion to <outliner> which just landed"

Finally, bug 116832 deals with favicons in bookmarks *personal toolbar and menu*
- there the problem is that the favicons are not displayed when Mozilla is
started (even if the bookmarks file contains them) and only appear when the site
is visited again. It also seems that sometimes some favicons would not appear in
toolbar and menus of a newly opened browser window even though they appear in an
older window.

-----

Did I get it right this time?

Is it time to create a tracking bug to help avoid confusing different issues?
Blocks: 120352
Target Milestone: mozilla0.9.9 → mozilla1.0.1
Until the build of the 2nd February the favicons are always lost (in bookmarks
and personal toolbar) if the Mozilla crashes. This is reproducible every time.
Carsten, this is a known problem, but it's separate from this one. It is
reported in bug 114824
-> ben
Assignee: blaker → ben
Status: ASSIGNED → NEW
Target Milestone: mozilla1.0.1 → ---
Blocks: 127154
*** Bug 127154 has been marked as a duplicate of this bug. ***
Bookmark favicons are out for this release :(
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → Future
Bug 127349 removed favicons/site icons from the personal toolbar and bookmarks
menubar, so I am updating the summary to list more places where favicons need to
be returned to...

Hopefully some of that could be brough back early in 1.1 cycle (so that some of
the bugs that caused favicons to be dropped could be fixed for 1.1).
Keywords: mozilla1.1
Summary: favicons & branded search icons lost in bookmarks window/sidebar → favicons & branded search icons lost in bookmarks window/sidebar/toolbar/menu
This bug blocks all the other bugs that talk about favicons in bookmarks
window/sidebar/toolbar/menu (obviously they are meaningless until the favicons
are added back).
*** Bug 129483 has been marked as a duplicate of this bug. ***
maybe someone could make this apref, and attach a new patch? I miss this as well.
Bug 127349 removed favicons from more places, so I am uptading the "Reverse bug
127349" attachment.

This patch is simply a reversal of attachment 72265 [details] [diff] [review] and attachment 73483 [details] [diff] [review] of bug
127349. Hopefully it can be extended to make favicons in toolbar
pref-controllable...
Attachment #72465 - Attachment is obsolete: true
Depends on: 131393
*** Bug 132828 has been marked as a duplicate of this bug. ***
Just a hint, but I see a lot of people CCing themselves to this bug (around 25 
now!) -- but only six votes for it.  You guys who haven't voted should do so.
My vote is on bug #113430 ("Various favicon caching problems"), which is the
issue that is causing the complaints seen in comment #9, etc.
Well, yes, but you can vote for more than one thing at a time.
*** Bug 137102 has been marked as a duplicate of this bug. ***
More "anti-favicons" stuff was checked in from bug 127349, so I am updating
this patch to match it.

Can we get this checked into the trunk now? Or do we have to wait for more
branching to occur before we could do it. In would be nice if this could go in
as soon as possible, so that we have more time to make favicons work better by
1.1 release.
Attachment #74530 - Attachment is obsolete: true
wow, this is great, thanks for maintaining this patch. I've mentioned this
before in other bugs, but a neat little hack (and one that would work with moz
1.0) would be to make a dynamic overlay that is user-installable, which contains
all these attribute additions... then those of us who are willing to deal with
the funky caching issues could install it and have favicons, without leaving a
half-finished feature in the actual product.
*** Bug 143348 has been marked as a duplicate of this bug. ***
Can we get toolbar favicons enabled on the trunk again? Can somebody pls review
attachment 79051 [details] [diff] [review]? Thanks!
Keywords: review
Target Milestone: Future → ---
Updating some bug descriptions to cut down on confusion per comment 11, which
also brings this bug back to its original intent.  Filed bug 143687 to take care
of reversing bug 127349, and attached Aleksey's patch.
Summary: favicons & branded search icons lost in bookmarks window/sidebar/toolbar/menu → Add site icons (favicons) to sidebar, manage bookmarks, and history
All CC's added to this bug after 2002-03-04 have been added to bug 143687.
Keywords: mozilla1.1, patch, review
Blocks: 114692
Comment on attachment 79051 [details] [diff] [review]
Reverse bug 127349, bring favicons back to personal toolbar and bookmarks menu

This is now known as attachment 83202 [details] [diff] [review] on bug 143687
Attachment #79051 - Attachment is obsolete: true
*** Bug 145438 has been marked as a duplicate of this bug. ***
*** Bug 146889 has been marked as a duplicate of this bug. ***
oON my comp (win98 SE) favicons only show in the adress bar thay dont show in;
Personal bar
Bookmarks dropdown box
top left hand corner by the title
*** Bug 147304 has been marked as a duplicate of this bug. ***
*** Bug 156663 has been marked as a duplicate of this bug. ***
*** Bug 159381 has been marked as a duplicate of this bug. ***
Blocks: majorbugs
Is there any progress being made on this bug?
1.2 is already coming out in alfa builda and nothing seems to be happening for
this bug that seems so simply to fix... (at least konqueror does a great job on
dealing with favicons).
actually, no progress with the 1.3a
This bug doesn't exist for the Phoenix project !!
So, Why is it not resolve for Mozilla ?
:(
i would really like this to be fixed.
it seems that every day there is a new site that i load that has an icon.
i think that is making this a more important feature to have fixed, the fact
that the icons are becoming more popular.
I not only agree as I do not understand why favicons isn't already a standard.
It's much easier to manage bookmarks that have different icons, this is because
visual (and not reading) identification.

I use phoenix, it have this feature (with the bugs of when mozilla had it), but
the browser that really gets the thing is konqueror. Int it you can even choose
any icon you have for a bookmark, you can have different icons for icons folders
too (I've used this to make distinction between folders and it's great).
*** Bug 188790 has been marked as a duplicate of this bug. ***
vote for this bug !
123 votes...nice but no progress :)
face it, votes don't matter. You have to actually submit a patch to make any
progress around here.
> face it, votes don't matter. You have to actually submit a patch to make any
> progress around here.

Bug 143687 "Bring back site icons (favicons) in personal toolbar" has *both* 84
votes and a patch that have been around for 3 months already, and still I can
not get any activity! What makes you think I'll have better luck if I invest
time into figuring out how to add the icons to sidebar and manage bookmarks?
*** Bug 195765 has been marked as a duplicate of this bug. ***
*** Bug 195974 has been marked as a duplicate of this bug. ***
-> me
Assignee: ben → varga
Status: ASSIGNED → NEW
Target Milestone: --- → mozilla1.4alpha
Blocks: 196756
*** Bug 198170 has been marked as a duplicate of this bug. ***
(you should probably accept the bug?)
The bookmarks branch has landed.
Fixed (except history). Not sure if we should keep this open.
Confirming that sidebar bookmarks and bk manager both show favicons with Mach-o
(2003-03-25-03) and Win32 (2003-03-26-04) trunk builds. But as Jan mentions,
History window won't display them.
The icons do not appear in the bookmarks bar (above display window).
Re: comment #58

> The icons do not appear in the bookmarks bar (above display window).

That is a separate bug - bug 143687
Using biuld 2003032611 I cannot see the fav icons nor on the PT, nor in sidebar,
nor in bookmark manager.

I have an old profile with a bookmark file. I open ixbt.com and see the icon in
URLbar, but it does not appers elsewhere. What I'm doing wrong?
For me with build 2003032708, the icons show up in the bookmark manager if and
only if I visit a site while that window is open. Closing it and reopening loses
everything. (Has any attempt been made to actually address the caching problems?)

Also, I noticed that my http://www.mozillaZine.com/ didn't show an icon until I
changed the Z to z. Off to search for a case-sensitivity bug. :)
Maybe that's because the correct address is mozillazine.org (not .com)?
:) no no, it's actually right in my bookmarks. The issue is indeed the
capitalization.
Is there a bug for history sidebar ?
A bug has been reported for the sidebar, bug 210480.
*** Bug 211038 has been marked as a duplicate of this bug. ***
*** Bug 213399 has been marked as a duplicate of this bug. ***
*** Bug 223622 has been marked as a duplicate of this bug. ***
*** Bug 229680 has been marked as a duplicate of this bug. ***
*** Bug 231235 has been marked as a duplicate of this bug. ***
*** Bug 250618 has been marked as a duplicate of this bug. ***
Severity: normal → enhancement
This can be almost perfectly solved by setting the prefs item
browser.chrome.load_toolbar_icons to 2 (not 1!). Works for Bookmarks Manager,
Bookmarks tab in sidebar and for the Personal Toolbar. The History tab seems to
be the only problem. But why can't this prefs item be reached in the Preferences
window? At the moment about:config is the only way to do it.

Is anything happening with this bug? I still see it with build Mozilla/5.0 (X11;
U; Linux i686; en-US; rv:1.7.2) Gecko/20040804 MultiZilla/1.6.4.0b. Firefox
(preview release) doesn't have this problem
When I switched from Classic to Modern theme, all favicons appeared again in the
bookmark manager (they were always present in the toolbar and in the URL input
field),
(In reply to comment #74)
> When I switched from Classic to Modern theme, all favicons appeared again in the
> bookmark manager (they were always present in the toolbar and in the URL input
> field),

  What build?  I am not seeing any of this in modern.
Right, it seems that it's the switching of themes that restores the favicons. At
work (SuSE 9.0 Professional) I switched from Classic to Modern, which restored
the icons. At home on Win XP SP2 I switched from Modern to Classic, and the
icons reappeared. On both systems I made sure the relevant preferences were set.
(In reply to comment #76)
> Right, it seems that it's the switching of themes that restores the favicons. At
> work (SuSE 9.0 Professional) I switched from Classic to Modern, which restored
> the icons. At home on Win XP SP2 I switched from Modern to Classic, and the
> icons reappeared. On both systems I made sure the relevant preferences were set.

 Again, what build is this?  I can not reproduce this on 1.7.3 stable.
(In reply to comment #77)

At home I'm using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

I'll have to check the exact build at the office; I believe it's 1.7.2; in any
case it's the build that comes preinstalled with SuSE 9.0 Professional
At work the build is:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040804 MultiZilla/1.6.4.0b

Granted, these are not the newest builds, but if the bug has been fixed in a
later build, shouldn't this be marked as resolved? 
(In reply to comment #79)
 
  I believe your case is unique.  I have talked to several other people that
still do not see favicons in the toolbar dropdown or in the bookmark menu, and I
cannot reproduce this fix on three different systems (two with 1.7.2 and one
with 1.7.3).
Product: Browser → Seamonkey
I have firefox 1.0 (Windows), and there is no browser.chrome.load_toolbar_icons
pref in about:config.  Am I SOL for even a workaround?
(In reply to comment #81)
> I have firefox 1.0 (Windows), and there is no browser.chrome.load_toolbar_icons
> pref in about:config.  Am I SOL for even a workaround?

Right click in about:config and create a new Integer Pref (Right Click -> New ->
Integer). Give browser.chrome.load_toolbar_icons as the pref name and 2 as the
pref value.
(In reply to comment #81)

> I have firefox 1.0 (Windows), and there is no browser.chrome.load_toolbar_icons
> pref in about:config. 

If I understand correctly (I might be mistaken), Firefox manages icons
differently from Mozilla App Suite. Namely, it just stores a cached favicon in
the bookmarks file itself. If you have imported bookmark file from anothe app
(such as Mozilla), favicons would not show up until you vsit the site in Firefox.
No longer blocks: majorbugs
Wouldn't setting these prefs as defaults help?

user_pref("browser.chrome.favicons", true);
user_pref("browser.chrome.site_icons", true);
user_pref("browser.chrome.load_toolbar_icons", 2);

In SeaMonkey 1.9a1 favicons already work with the above prefs enabled. Also,
with every new profille created, there should be a user.js included to be sure
they'll always be active.
In firefox ( Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 ) favicon is not displaying at top left hand corner by the title, Bookmarks tab in Sidebar, history sidebar.
As comment 84 says, it all seems to work. Anybody still seeing a problem?

pi
(In reply to comment #86)
> As comment 84 says, it all seems to work. Anybody still seeing a problem?

In SeaMonkey 1.1.1, using about:config to change the settings as indicated in comment 84 seems to remedy all the problem here.  Site icons (favicons) are visible on the tabs, in the Bookmarks menu (and submenues), in the Personal Toolbar File menu, and in the sidebar.

No, I am no longer seeing a problem with this.

> 
> pi
> 

Still think it should get a GUI.
Also, unless someone can quantify a significant performance hit, should consider making browser.chrome.load_toolbar_icons = 2  as default.
I am not sure, what exactly the setting under "Appearance" does. But anyhow, a GUI would be another bug (which proably does exist). Closing this bug.

pi
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
> Wouldn't setting these prefs as defaults help?
> 
> user_pref("browser.chrome.favicons", true);
> user_pref("browser.chrome.site_icons", true);
> user_pref("browser.chrome.load_toolbar_icons", 2);

In Firefox 2.0.0.2 rv:1.8.1.2 build 20070219, 
 user_pref("browser.chrome.favicons", true);
 user_pref("browser.chrome.site_icons", true);
are default values.

With Seamonkey 1.5a rv:1.9a3pre build 2007030408,
 user_pref("browser.chrome.favicons", true);
 user_pref("browser.chrome.load_toolbar_icons", 2);
are NOT the default values.

Dimos, I agree with you that setting these preferences as defaults would help, would be beneficial for newcomers.
SeaMonkey won't ever stupidly look for a favicon.ico without knowing (ie by a <link> tag) it's there - if that's what you propose...
Changing the settings as indicated in Comment #84 indeed show favicons in the bookmark menu, but only once the bookmark has been visited.  Is there some way of refreshing the entire bookmark tree so that all favicons are fetched and displayed?
You need to log in before you can comment on or make changes to this bug.