Closed Bug 1135747 Opened 5 years ago Closed 5 years ago

[RTL][Contacts] The large central letter icons do not appear when navigating / pressing on the quicksearch side-bar in the list of contacts.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S7 (6mar)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: jmitchell, Assigned: autra)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(3 files)

Description:
In the contacts app there is a list of letters descending down the side of the screen. This is the quicksearch bar and the user can use it to navigate to a certain area of the contacts. This is particularly useful for large contacts list. The sidebar is very small and difficult to navigate so when pressing on the sidebar a large icon appears central-screen indicating the letter of the area of the sidebar currently being pressed (to assist in navigation / use). These icons do not appear when in RTL.

Repro Steps:
1) Update a Flame to 20150223010224
2) Launch Contacts app and import or create several contacts
3) Use the side-bar / quicksearch bar by scrolling up and down on it

Actual:
Large associated alphabet icon does not appear.

Expected:
Large letter icons will appear as the sidebar is navigated / used

Environmental Variables:
Device: Flame 3.0
Build ID: 20150223010224
Gaia: a6881205deae450757a8d1e1ed65e5e5be0ec633
Gecko: 86d2bb8bb1c9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 7/7
See attached: logcat, video: http://youtu.be/UmYQ6evIJ78
This issue does not occur in 2.2

Actual results: The large central letters appears when scrolling the quicksearch bar

Notes: The quicksearch bar is on the left side of the screen instead of the right as in 3.0 so what ever patch moved the quicksearch bar back over to the right side (per design due to right-handedness) *might* be responsible for this issue.
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Functional regression of a supported feature.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [rtl-impact]
Flags: needinfo?(pbylenga)
QA Contact: pcheng
Comment 1's assumption is correct.

b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20150219204401
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: 1b4c5daa7b7a
Version: 38.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20150220053248
Gaia: 9ae9b1410296db55d25e50c3afa63720ff691256
Gecko: dff32a7c1524
Version: 38.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: dff32a7c1524

Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: 9ae9b1410296db55d25e50c3afa63720ff691256
Gecko: 1b4c5daa7b7a

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3...9ae9b1410296db55d25e50c3afa63720ff691256

Caused by the patch for Bug 1134306.
QA Whiteboard: [rtl-impact] → [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Augustin, can you take a look at this please? Looks like the landing for bug 1134306 might have caused this to occur.
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(augustin.trancart)
Comment on attachment 8568196 [details] [review]
[gaia] autra:bug-1135747 > mozilla-b2g:master

Yes I forgot to overload a shared CSS rule for the contact scrollbar, sorry!

Jose, could you have a look at this? Especially, I didn't overload the html[dir="rtl"] nav[data-type="scrollbar"] p img  of scrolling.css in shared style, I didn't think it is used in contact list scrollbar. What do you think about that?
Flags: needinfo?(augustin.trancart)
Attachment #8568196 - Flags: review?(jmcf)
Assignee: nobody → augustin.trancart
Comment on attachment 8568196 [details] [review]
[gaia] autra:bug-1135747 > mozilla-b2g:master

LGTM

thanks
Attachment #8568196 - Flags: review?(jmcf) → review+
Bug 1134306 has been uplifted to 2.2, 7 hours ago.
blocking-b2g: 3.0? → 2.2?
Triage: Broken functionality while in RTL mode, which is a feature for 2.2.
blocking-b2g: 2.2? → 2.2+
Johan - that does not make it 'not-a-regression'
Keywords: regression
Keywords: checkin-needed
Priority: -- → P1
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8568196 [details] [review]
[gaia] autra:bug-1135747 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
RTL
[User impact] if declined:
Bad user experience
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
Low
[String changes made]:
None
Attachment #8568196 - Flags: approval-gaia-v2.2?
This issue is verified fixed on Flame 3.0 nightly. The selected letter's icon appears in center of screen when using on the quick search side bar.

Device: Flame 3.0 Master (full flash 319MB)
BuildID: 20150225010244
Gaia: f6bfd854fe4746f21bc006eac145365e85f98808
Gecko: 0a8b3b67715a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Adding verifyme keyword for verifying on 2.2 after uplifting.
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact][QAnalyst-Triage+] → [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Attachment #8568196 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Attached image verify_pass.png
This issue has been verified as "Pass" on latest build of Flame 2.2 and Nexus5 2.2/3.0 by STR in comment 0.
Result: The selected letter's icon appears in center of screen when using on the quick search side bar.
See attachment: verify_pass.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150617002504
Gaia Revision          3414b07dc489976bf510fd8042c0af3b1192c160
Gaia Date              2015-06-16 22:04:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a2db74491088
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150617.040422
Firmware Date          Wed Jun 17 04:04:34 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (pass)
Build ID               20150617002504
Gaia Revision          3414b07dc489976bf510fd8042c0af3b1192c160
Gaia Date              2015-06-16 22:04:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a2db74491088
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150617.042332
Firmware Date          Wed Jun 17 04:24:07 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (pass)
Build ID               20150617160207
Gaia Revision          b404c41c5471c31610e64defb74ec066b411e724
Gaia Date              2015-06-17 17:01:15
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a3f280b6f8d5
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150617.192258
Firmware Date          Wed Jun 17 19:23:17 EDT 2015
Bootloader             HHZ12f
QA Whiteboard: [rtl-impact][QAnalyst-Triage+] → [rtl-impact][QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.