Client Widow at Fullscreen is Missing "Mute" Functionality

RESOLVED DUPLICATE of bug 1000281

Status

Hello (Loop)
Client
RESOLVED DUPLICATE of bug 1000281
3 years ago
3 years ago

People

(Reporter: Arthur Ketcham, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150223004020

Steps to reproduce:

Join a Firefox Hello session using a link, right click on the video, choose "Full Screen". 

Right click on the full screen video, and choose "Show Controls"


Actual results:

There are two possible UI elements for "Mute" functionality. In the context menu, the "Mute" option mutes the incoming remote sound. The "mute" icon in "show controls" is broken. There is no UI ability to mute the local microphone. (Which is my needed functionality, as we use Full Screen hello for Telepresence and need to have clients have the ability to self-mute)


Expected results:

Clients need the ability to have a full-screen session, but be able to mute or unmute from the full-screen UI. There should be an option, either in the context menu, shown controls, or both for "Mute Microphone".
The issue is that you're doing full-screen on the video stream itself (just like you can do on any html5 video on other websites).

We haven't yet implemented a full-screen mode which would allow you to view the video controls as well. This work will be done in bug 1000281.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1000281
You need to log in before you can comment on or make changes to this bug.