Keyboard hides during rocketbar input

RESOLVED DUPLICATE of bug 1134493

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1134493
3 years ago
3 years ago

People

(Reporter: kgrandon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Bug 1129344 was fixed, though I'm still seeing this on master.
(Reporter)

Comment 1

3 years ago
git bisect start
git bisect good 2f42a5b6a999aca41858d36076c1f5ffdbfa9021
git bisect bad 535c18d33344d21e4189fe443db5c661d5718762
Bisecting: 434 revisions left to test after this (roughly 9 steps)
[2cbf5a7090353b97b41d1be92d5beae342504902] Merge pull request #27950 from steveck-chung/message-text-selection-polish

git bisect bad
Bisecting: 216 revisions left to test after this (roughly 8 steps)
[97f3b4d11a92bdcaf79edd8ff55e690bd446bac7] Merge pull request #27907 from RickyChien/bug-1128844

git bisect good
Bisecting: 108 revisions left to test after this (roughly 7 steps)
[bbc853ff4d1bffad41d19bb47e066e3ba21c6709] Merge pull request #27987 from sfoster/ftu-rtl-switches-bug-1010615

git bisect good
Bisecting: 53 revisions left to test after this (roughly 6 steps)
[ca3806d22b606152af1ccc8491d6eefed89517fe] Merge pull request #28056 from dwi2/bug1130701

git bisect good
Bisecting: 26 revisions left to test after this (roughly 5 steps)
[e69e07028d407a4fd23289ded91451688d19a851] Merge pull request #28031 from yzen/bug-1069601

git bisect bad
Bisecting: 13 revisions left to test after this (roughly 4 steps)
[7a36fbde2133f6f9cbf828e295835b865a94e4ce] Merge pull request #27570 from viorelaioia/bug_1122448

git bisect good
Bisecting: 7 revisions left to test after this (roughly 3 steps)
[eddf2fd8b75624557d59bec7f43ba1ab4e462efc] Merge pull request #27820 from gitmai/bug-1127807-adding-sendNotification-method

git bisect bad
Bisecting: 3 revisions left to test after this (roughly 2 steps)
[88ab02a2b2a02c1b0bbf954a35687d21f1c59a8f] Merge pull request #28066 from viorelaioia/bug_1130990

git bisect good
Bisecting: 1 revision left to test after this (roughly 1 step)
[a85b768ababe56fbb6c22bf09bf72b64e5eb0a59] Bug 1130011 - merge pull request #28061 from etiennesegonzac:bug-1130011 to mozilla-b2g:master

git bisect bad
Bisecting: 0 revisions left to test after this (roughly 0 steps)
[09e5f0b133b6d6021548b3e3fe8326d9e9a1420c] Bug 1130011 - Removing superfluous touch event listener on the whole window r=kgrandon

git bisect bad
09e5f0b133b6d6021548b3e3fe8326d9e9a1420c is the first bad commit
commit 09e5f0b133b6d6021548b3e3fe8326d9e9a1420c
Author: Etienne Segonzac <etienne@segonzac.info>
Date:   Thu Feb 5 18:59:17 2015 +0100

    Bug 1130011 - Removing superfluous touch event listener on the whole window r=kgrandon

This seems to have somehow been caused by removing the event listeners in bug 1130011.
Blocks: 1130011
(Reporter)

Comment 2

3 years ago
Etienne, Kats - I've confirmed that backing out the gaia patch in bug 1130011 makes this go away. It seems that we're not *actually* catching any events in those listeners though, so I assume we're going through some different APZ patch and triggering touch/focus events when we don't want them.

Any ideas?
Flags: needinfo?(etienne)
Flags: needinfo?(bugmail.mozilla)
I was likely experiencing the same problem in bug 1134493.
See Also: → bug 1134493
(Reporter)

Comment 4

3 years ago
(In reply to Botond Ballo [:botond] from comment #3)
> I was likely experiencing the same problem in bug 1134493.

Thanks. Let's dupe in that direction because you were much more detailed and I was lazy with the STR :)

I'll add details in that bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(etienne)
Flags: needinfo?(bugmail.mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1134493
You need to log in before you can comment on or make changes to this bug.