Closed Bug 113595 Opened 19 years ago Closed 16 years ago

Line breaks (as entities) in title attribute create excessive whitespace

Categories

(Core :: XUL, defect, trivial)

x86
Windows NT
defect
Not set
trivial

Tracking

()

VERIFIED DUPLICATE of bug 67127

People

(Reporter: herman, Assigned: hewitt)

References

()

Details

(Keywords: html4, Whiteboard: [HTML4-5.3.1][HTML4-7.4.3])

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112009

The given URL is an example of getting tooltip on anchor tags, the example given
uses html entities (

) in the title attribute of the A tag. This causes
the tooltip to contain a large amount of whitespace at the end, pushing the
actual text of the tooltip off the left of the screen.

Reproducible: Always
Steps to Reproduce:
1. Hover the mouse over the link "A100216: Adding ToolTips to your HTML pages."


Actual Results:  single line tooltip with a lot of whitespace appears

Expected Results:  multiline tooltip should appear

HTML Source for the relevant link:

<a href="/features/knowledge_base/a100216.html" title="ToolTips are
&#10;&#13;really neat!">
A100216: Adding ToolTips to your HTML pages.
</a>
Odd, on Linux I see two dotted boxes (e.g., unknown character markers) for the
entities.  Normally on Windows this manifests itself as black lines; see bug
67127.  Anyone else see this?
Here's a screenshot of the bug, as you can see, the text is still there, but is
pressed all the way to the left and doesn't fit on the screen entirely.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: mozilla1.0
Status: NEW → ASSIGNED
Target Milestone: --- → Future
--> default owner
Assignee: hyatt → jaggernaut
Status: ASSIGNED → NEW
Target Milestone: Future → ---
Summary: HTML entities in anchor title cause incorrect tooltip → Line breaks (as entities) in title attribute create excessive whitespace
Keywords: html4
Whiteboard: [HTML4-5.3.1][HTML4-7.4.3]
over to hewitt, who I've been advised is doing more of the tooltip work (sorry
for all the spam!)
Assignee: jaggernaut → hewitt
Is it to be expected that this bug will be fixed in the near future? I'm seeing
the unknown character marker on linux and I'm also experiencing the problem that
the tooltip is cut of after a certain length.
A maximal line lenght probably makes sense (although it's rather short right
now) but unless linebreaks - be it character references or a simple #13/#13#10
should please be made to work. I convinced the authors of a site
(www.empireuniverse.com - a browsergame) at least to duplicate the informations
from the alt attribute into the title attribute but now I still see only
shortened tooltips.
Is this a dupe of bug 67127?

*** This bug has been marked as a duplicate of 67127 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.