mozreview replaces the diff URL with one for a 404

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: MattN, Assigned: smacleod)

Tracking

Details

(Whiteboard: [fixed in core], URL)

STR:
1) Load https://reviewboard.mozilla.org/r/4209/
2) Click "[Diff]" for the first child commit (pointing to https://reviewboard.mozilla.org/r/4211/diff/#0).

Expected result: https://reviewboard.mozilla.org/r/4211/diff/#0 is in the URL bar so I can copy it out and send it to someone.
Actual result: The URL gets replaced with https://reviewboard.mozilla.org/r/4211/diff/0 (no "#"). Loading https://reviewboard.mozilla.org/r/4211/diff/0 leads to a 404.
This is fixed in Review Board 2.0.13, which we haven't upgraded to yet.
Whiteboard: [fixed in core]
Priority: -- → P1
Assignee: nobody → smacleod
Depends on: 1161792
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1163145
Duplicate of this bug: 1164169
Depends on: 1164932
No longer depends on: 1161792
2.0.15 is now deployed and this bug should be no more.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Product: Developer Services → MozReview
You need to log in before you can comment on or make changes to this bug.