Closed Bug 1135976 Opened 5 years ago Closed 5 years ago

[RTL][Privacy Controls] Overlapping text in Transparency Control Permissions page

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S7 (6mar)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: pcheng, Assigned: GaryChen)

References

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(3 files)

Attached image screenshot of issue
Description:
There are overlapping text within Transparency Controls page.

Prerequisite:
In RTL language

STR:
1) Navigate to Settings > Privacy Controls > Transparency Control > Permissions

Expected: No overlapping text with buttons. Text should be correctly truncated.

Actual: Overlapping text with buttons. See screenshot.

Tested on:
Device: Flame 3.0
BuildID: 20150223103044
Gaia: 288bf1c58ef9ccecd68508978a0141ee71974681
Gecko: 9b077c6f3d02
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
This issue also occurs on Flame 2.2.

Device: Flame 2.2 (full flashed 319MB mem)
BuildID: 20150220002501
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: b864abe1c6b3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Blocks: settings-rtl
QA Whiteboard: [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [3.0-Daily-Testing]
Priority: -- → P2
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Assignee: nobody → gchen
Attached file PR for master
Hi marta,
   I use '-moz-padding-start' instead of 'padding-left' for fixing RTL.
   Could you help to take a look?
   Thanks.
Attachment #8568992 - Flags: review?(marta)
Attachment #8568992 - Flags: review?(marta) → review+
blocking-b2g: --- → 2.2?
land in master:
https://github.com/mozilla-b2g/gaia/commit/ed1322ed18d9a947acd0ef9d500dfb89fb3f17cd
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8568992 [details] [review]
PR for master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: bad user experience.
[Testing completed]:
https://treeherder.mozilla.org/#/jobs?repo=gaia-try&revision=6de87d49a6a3
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: N/A
Attachment #8568992 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8568992 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed on Flame 3.0 and Flame 2.2. Text is correctly truncated and no overlapping text appears.

Device: Flame 3.0 Master (full flash 319MB)
BuildID: 20150304010324
Gaia: 3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gecko: c5b90c003be8
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (full flash 319MB)
BuildID: 20150304002529
Gaia: 8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gecko: 2cb52b7cda5a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact][QAnalyst-Triage+] → [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15741/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.