Un-hide Language > Get More Languages

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Settings
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: stas, Assigned: stas, NeedInfo)

Tracking

unspecified
2.2 S7 (6mar)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
The langpack support is now live on Marketplace.  Let's show the link again.
Created attachment 8568399 [details] [review]
[gaia] stasm:1136025-unhide-get-more-languages > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Depends on: 1126247
(Assignee)

Comment 2

3 years ago
Comment on attachment 8568399 [details] [review]
[gaia] stasm:1136025-unhide-get-more-languages > mozilla-b2g:master

Arthur, this un-does the change from bug 1126247.
Attachment #8568399 - Flags: review?(arthur.chen)
Comment on attachment 8568399 [details] [review]
[gaia] stasm:1136025-unhide-get-more-languages > mozilla-b2g:master

r=me, thanks.
Attachment #8568399 - Flags: review?(arthur.chen) → review+
(Assignee)

Comment 4

3 years ago
Thanks, Arthur!

https://github.com/mozilla-b2g/gaia/commit/4304237a77dde96195bdbb813b77905aea1e5169
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

3 years ago
Comment on attachment 8568399 [details] [review]
[gaia] stasm:1136025-unhide-get-more-languages > mozilla-b2g:master

[Approval Request Comment]

[Bug caused by] (feature/regressing bug #):  Bug 1126247 in which we "prefed off" langpacks by hiding the link to the Marketplace

[User impact] if declined:  The UI to discover langpacks will be hidden.

[Testing completed]: on the device

[Risk to taking this patch] (and alternatives if risky): very very low

[String changes made]: none
Attachment #8568399 - Flags: approval-gaia-v2.2?(bbajaj)
(Assignee)

Comment 6

3 years ago
Sorry if the approval request comes a little late but I wanted to make sure the Langpack support makes it to the production Marketplace before we make this change.

Updated

3 years ago
Attachment #8568399 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
(Assignee)

Updated

3 years ago
Blocks: 1107341
Keywords: checkin-needed
v2.2: https://github.com/mozilla-b2g/gaia/commit/f2af8f80dcb0025db638fa698bb976488c2f4b4c
Assignee: nobody → stas
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Keywords: checkin-needed
Target Milestone: --- → 2.2 S7 (6mar)
This issue is verified fixed on the latest Nightly 3.0 and 2.2 builds
	
Actual results:  The Get More Languages link is no longer hidden under settings.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150226010233
Gaia: 7894b929f1b0394f3c997f72a6482bc7813e758d
Gecko: dd6353d61993
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150226002503
Gaia: bf24aa57fa7760260ab05d1f53242c8d8ae59e83
Gecko: 363123044e61
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+]
You need to log in before you can comment on or make changes to this bug.