Gaia Notes: ASCII regular spaces (0x20) wrongly converted to   - seen when attached to Gaia Email message

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
8 months ago

People

(Reporter: hellosct1, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(tracking-b2g:+, b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(1 attachment)

85.13 KB, application/x-zip-compressed
Details
(Reporter)

Description

4 years ago
Created attachment 8568450 [details]
screensaver bug char space

User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36

Steps to reproduce:

I have used and ÉCRI a NOTES (see image1)


Actual results:

when I shared my NOTES for the email, the characters "space" are not properly converted (see image2)


Expected results:

Problem interprétration character [SPACE] between ASCII and HTML
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.2?
I was able to reproduce on 2.1[1]. I couldn't find any encoding bug in Gaia::Notes. John, do you know if encoding is a known issue in the Notes app?

Clearing the nomination while we get more information.

[1] Build ID               20150220001208
Gaia Revision          373df4bec2c20228f45be0b24111252171f925e9
Gaia Date              2015-02-19 13:52:34
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/10c100cba54d
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20141120.194707
Firmware Date          Thu Nov 20 19:47:17 EST 2014
Bootloader             L1TC00011880
Status: UNCONFIRMED → NEW
blocking-b2g: 2.2? → ---
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Component: General → Gaia::Notes
Ever confirmed: true
Flags: needinfo?(jdorlus)
Hi Johan. This is a valid new bug. It was not a known issue. It's also, not a regression.
Flags: needinfo?(jdorlus)
It's a major issue, but as we dealt with for a serious amount of time. I don't see any other criteria[1] which would make this issue as a release blocker. John, do you know think we can ask the Productivity team to put this bug in their high priority bug list?

[1] https://wiki.mozilla.org/B2G/Triage#Blocker_Triage_Guidelines
[Tracking Requested - why for this release]: This is a serious issue but cannot be prioritized as high priority right now due to the overall priority of the notes app. Spoke to the productivity team (doliver) and he agrees to set to tracking-b2g.
tracking-b2g: --- → ?
tracking-b2g: ? → +
(Reporter)

Comment 5

4 years ago
If it helps you
I reproduce this problem only when I use the share function
If I use the functions of copy / paste, the problem does not exist


Si cela peut vous aider
je reproduis ce probleme seulement quand j'utilise la fonction partage
Si j'utilise les fonctions de copier/coller, le problème n'existe pas
Merci
I'm aware that Firefox OS has been abandoned, but coming from MailNews Core bug 290565, I just wanted to clarify which direction this bug was going. So strange that where users entered normal spaces, they get non-breaking spaces (like this bug here), and where they entered non-breaking spaces, they get normal spaces (bug 290565). I guess generally speaking we should just try to keep what the user actually entered, and stop automagical conversions, which always tend to come out wrong at some point.
Summary: encoding ASCII [space] to   with API NOTES → Gaia Notes: ASCII regular spaces (0x20) wrongly converted to   - seen when attached to Gaia Email message

Comment 7

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.