crash in `anonymous namespace''::wasapi_stream_start(cubeb_stream*)

VERIFIED FIXED in Firefox 38

Status

()

Core
Audio/Video
--
critical
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Xavier Delgado, Assigned: kinetik)

Tracking

39 Branch
mozilla39
x86
Windows 8.1
Points:
---

Firefox Tracking Flags

(firefox38 fixed, firefox39 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150223103044

Steps to reproduce:

1) Launch FF39 Nightly on 8.1
2) Launch a youtube video
3) Click "Pause"
4) Unplug speaker audio output jack (Terratec Aureon 7.1 USB)
5) Plug headphones output jack



Actual results:

Firefox crashes


Expected results:

I should have continue to listen video with headphones
More reports: https://crash-stats.mozilla.com/signature/?signature=%60anonymous+namespace%27%27%3A%3Awasapi_stream_start(cubeb_stream*)&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&page=1

Updated

3 years ago
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

3 years ago
Simple fix, the assert in wasapi_stream_start is overly cautious.
Assignee: nobody → kinetik
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
status-firefox38: --- → affected
status-firefox39: --- → affected
(Assignee)

Comment 2

3 years ago
Created attachment 8571151 [details] [diff] [review]
Handle reconfiguring audio device if it went away while the stream was stopped
(Assignee)

Comment 3

3 years ago
Comment on attachment 8571151 [details] [diff] [review]
Handle reconfiguring audio device if it went away while the stream was stopped

Actually not just an assert.  Problem is that the default audio device has gone away while the stream has stopped, and we don't expect to need to reconfigure it when restarting the stream.
Attachment #8571151 - Flags: review?(padenot)

Updated

3 years ago
Attachment #8571151 - Flags: review?(padenot) → review+
(Assignee)

Comment 4

3 years ago
This patch should also take care of the wasapi_stream_stop crashes that show up in the crash stats for 39.0a1.
(Assignee)

Comment 5

3 years ago
That applies to 38.0a2 as well.
(Assignee)

Comment 7

3 years ago
Comment on attachment 8571151 [details] [diff] [review]
Handle reconfiguring audio device if it went away while the stream was stopped

Approval Request Comment
[Feature/regressing bug #]: bug 698079/bug 1134078
[User impact if declined]: Crash (fatal assertion) when pausing or resuming playback after the audio device has changed
[Describe test coverage new/current, TreeHerder]: n/a
[Risks and why]: low risk
[String/UUID change made/needed]: none
Attachment #8571151 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

3 years ago
Blocks: 1134078
https://hg.mozilla.org/mozilla-central/rev/d6d887fcc49c
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox39: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39

Updated

3 years ago
QA Whiteboard: [good first verify]
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

3 years ago
No longer reproducible with latest Nightly from 2015-03-08 on Windows 8.1. Changed the status accordingly.

But if you plug and unplug audio jacks on YouTube without clicking "Pause", the sound doesn't work.
However, it was like that before.

Updated

3 years ago
status-firefox39: fixed → verified
Attachment #8571151 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1143540
You need to log in before you can comment on or make changes to this bug.