Latest nightly build crashes on first page load Trunk [@ GetBorderColor][@ nsCSSRendering::DrawCompositeSide]

RESOLVED FIXED

Status

()

Core
XUL
--
blocker
RESOLVED FIXED
17 years ago
7 years ago

People

(Reporter: Peter O'Shea, Assigned: David Hyatt)

Tracking

({crash, topcrash})

Trunk
x86
All
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Build 2001120422 for Solaris crashes on first page load, running on Solaris 8. 
The crash only occurs on external sites that I access through the company's
proxy server, not on internal, non-proxied sites.

Following is a backtrace:


#0  0xfeb33064 in strlen ()
#1  0xfdcacb9c in ?? () from /home/poshea/bin/mozilla/components/libnecko.so
#2  0xfdcac398 in ?? () from /home/poshea/bin/mozilla/components/libnecko.so
#3  0xfdca77f8 in ?? () from /home/poshea/bin/mozilla/components/libnecko.so
#4  0xfdca7b4c in ?? () from /home/poshea/bin/mozilla/components/libnecko.so
#5  0xfdca2b1c in ?? () from /home/poshea/bin/mozilla/components/libnecko.so
#6  0xfdc9bb30 in ?? () from /home/poshea/bin/mozilla/components/libnecko.so
#7  0xfdc5c6ec in ?? () from /home/poshea/bin/mozilla/components/libnecko.so
#8  0xfd99ab94 in ?? () from /home/poshea/bin/mozilla/components/libimglib2.so
#9  0xfd0b9c14 in ?? () from /home/poshea/bin/mozilla/components/libgklayout.so
#10 0xfd0b9748 in ?? () from /home/poshea/bin/mozilla/components/libgklayout.so
#11 0xfd0b939c in ?? () from /home/poshea/bin/mozilla/components/libgklayout.so
#12 0xfd079710 in ?? () from /home/poshea/bin/mozilla/components/libgklayout.so
#13 0xfd753874 in ?? () from /home/poshea/bin/mozilla/components/libgkcontent.so
#14 0xfd01e990 in ?? () from /home/poshea/bin/mozilla/components/libgklayout.so
#15 0xfd69899c in ?? () from /home/poshea/bin/mozilla/components/libgkcontent.so
#16 0xfd67f8bc in ?? () from /home/poshea/bin/mozilla/components/libgkcontent.so
#17 0xfd67c154 in ?? () from /home/poshea/bin/mozilla/components/libgkcontent.so
#18 0xff1c9204 in XPTC_InvokeByIndex ()
#19 0xfdec3a78 in ?? () from /home/poshea/bin/mozilla/components/libxpconnect.so
#20 0xfdec9dc4 in ?? () from /home/poshea/bin/mozilla/components/libxpconnect.so
#21 0xff2b679c in js_Invoke ()
#22 0xff2be254 in js_Interpret ()
#23 0xff2b67f0 in js_Invoke ()
#24 0xfdebeecc in ?? () from /home/poshea/bin/mozilla/components/libxpconnect.so
#25 0xfdebb628 in ?? () from /home/poshea/bin/mozilla/components/libxpconnect.so
#26 0xff1c79b8 in PrepareAndDispatch ()
#27 0xff1c9248 in SharedStub ()
#28 0xff1c7a74 in nsXPTCStubBase::Stub5 ()
#29 0xfdb12924 in ?? () from /home/poshea/bin/mozilla/components/liburiloader.so
#30 0xfda621f0 in ?? () from /home/poshea/bin/mozilla/components/libdocshell.so
#31 0xfda60f00 in ?? () from /home/poshea/bin/mozilla/components/libdocshell.so
#32 0xfda61fb0 in ?? () from /home/poshea/bin/mozilla/components/libdocshell.so
#33 0xfda5c26c in ?? () from /home/poshea/bin/mozilla/components/libdocshell.so
#34 0xfda6bc34 in ?? () from /home/poshea/bin/mozilla/components/libdocshell.so
#35 0xfdb0efac in ?? () from /home/poshea/bin/mozilla/components/liburiloader.so
#36 0xfdb0e83c in ?? () from /home/poshea/bin/mozilla/components/liburiloader.so
#37 0xfdca3b64 in ?? () from /home/poshea/bin/mozilla/components/libnecko.so
#38 0xfdca39fc in ?? () from /home/poshea/bin/mozilla/components/libnecko.so
#39 0xfdcaa0c8 in ?? () from /home/poshea/bin/mozilla/components/libnecko.so
#40 0xfdcc9728 in ?? () from /home/poshea/bin/mozilla/components/libnecko.so
#41 0xfdc62794 in ?? () from /home/poshea/bin/mozilla/components/libnecko.so
#42 0xff1aefe8 in PL_HandleEvent ()
#43 0xff1aef18 in PL_ProcessPendingEvents ()
#44 0xff1affb0 in nsEventQueueImpl::ProcessPendingEvents ()
#45 0xfdfaefd8 in ?? () from /home/poshea/bin/mozilla/components/libwidget_gtk.so
#46 0xfdfaec8c in ?? () from /home/poshea/bin/mozilla/components/libwidget_gtk.so
#47 0xfee5406c in g_io_unix_dispatch (source_data=0x1c9640,
current_time=0xffbeecc8, user_data=0x1abd20) at giounix.c:135
#48 0xfee55d48 in g_main_dispatch (dispatch_time=0xffbeecc8) at gmain.c:656
#49 0xfee565e4 in g_main_iterate (block=-18367068, dispatch=1) at gmain.c:877
#50 0xfee567f8 in g_main_run (loop=0x1abd30) at gmain.c:935
#51 0xfefbf940 in gtk_main ()
#52 0xfdfaf574 in ?? () from /home/poshea/bin/mozilla/components/libwidget_gtk.so
#53 0xfe95ad90 in ?? () from /home/poshea/bin/mozilla/components/libnsappshell.so
#54 0x18144 in NS_CreateNativeAppSupport ()
#55 0x18c04 in main ()

Comment 1

17 years ago
Also seeing this on Linux 2001120508.

Comment 2

17 years ago
Sorry for the spam.  See talkbacks TB73728Y and TB73723Z.

Comment 3

17 years ago
I've just experienced several crashes loading bugzilla pages, using Linux build
pulled from the trunk at 0900GMT. I cleared ~/.mozilla, restarted, and still
crashes sometimes on bugzilla pages. These issues may be co-incidental.
Keywords: crash

Comment 4

17 years ago
from talkback: 

libc.so.6 + 0x51869 (0x404f6869)
libc.so.6 + 0x5173f (0x404f673f)
libstdc++-libc6.1-1.so.2 + 0x35e32 (0x405bde32)
nsImageFrame::DisplayAltFeedback()
nsImageFrame::Paint()
nsContainerFrame::PaintChild()
nsBlockFrame::PaintChildren()
nsBlockFrame::Paint()
nsContainerFrame::PaintChild()
nsContainerFrame::PaintChildren()
nsTableCellFrame::Paint()
nsTableRowFrame::PaintChildren()
nsTableRowFrame::Paint()
nsTableRowGroupFrame::PaintChildren()
nsTableRowGroupFrame::Paint()
nsContainerFrame::PaintChild()
nsContainerFrame::PaintChildren()
nsTableFrame::Paint()
nsContainerFrame::PaintChild()
nsTableOuterFrame::Paint()
nsContainerFrame::PaintChild()
nsBlockFrame::PaintChildren()
nsBlockFrame::Paint()
nsContainerFrame::PaintChild()
nsContainerFrame::PaintChildren()
nsTableCellFrame::Paint()
nsTableRowFrame::PaintChildren()
nsTableRowFrame::Paint()
nsTableRowGroupFrame::PaintChildren()
nsTableRowGroupFrame::Paint()
nsContainerFrame::PaintChild() 

Comment 5

17 years ago
Created attachment 60492 [details]
backtrace on Linux (non-debug CVS) (tried to load cnn.com)
I blame hyatt's image changes.

This worked froma build without them, and my current build which basically only
has those extra changes crashes.

The stack in comment 0 looks bogus/unrelated, though

I don't think proxies are related, and imglib is in the stack of the second one.
Hmm...
Assignee: neeti → hyatt
Status: UNCONFIRMED → NEW
Component: Networking → XP Toolkit/Widgets: XUL
Ever confirmed: true

Comment 7

17 years ago
PC/All. Is this smoketest?
OS: Solaris → All
Hardware: Sun → PC

Comment 8

17 years ago
Looks like a dup of bug 113618. Anyone confirm?

Comment 9

17 years ago
*** Bug 113638 has been marked as a duplicate of this bug. ***
Created attachment 60498 [details]
backtrace

Backtrace on linux; crash on first page paint
Hyatt checked in a fix; I tested it and the crash is gone.  Fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
*** Bug 113693 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 13

17 years ago
I'm still seeing the crash in build 2001120522 for Solaris.  Should the fix have
made it into this build?

Comment 14

17 years ago
Win2000

The first reporter has the same prob I had ystrday and w/this morning's build.  
I am also going through a proxy at work and as soon as I get the alert and 
enter my proxy username and pass and hit enter Moz crashes.  If I go to a local 
site everything works fine.  Plus I've used ystrday's build that crashed at 
work on my home comp (winMe) which isn't using any proxy and it works fine.  I 
think there is definitley some sort of proxy problem though
*** Bug 113811 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
Updating summary and marking topcrash for future talkback tracking.
Keywords: topcrash
Summary: Latest nightly build crashes on first page load → Latest nightly build crashes on first page load Trunk [@ GetBorderColor]
*** Bug 113829 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
Created attachment 60643 [details]
Stack Trace from duped bug 113693 for future reference

Comment 19

17 years ago
Adding [@ nsCSSRendering::DrawCompositeSide] to summary for tracking...since
that is the Linux version of this crash, as reported by Talkback and logged in
other bugs that are marked dups of this one.
Summary: Latest nightly build crashes on first page load Trunk [@ GetBorderColor] → Latest nightly build crashes on first page load Trunk [@ GetBorderColor][@ nsCSSRendering::DrawCompositeSide]

Comment 20

17 years ago
*** Bug 114016 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 21

17 years ago
Seems to be working now in build 2001120622 for Solaris.

Comment 22

17 years ago
*** Bug 113636 has been marked as a duplicate of this bug. ***

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: benc → xptoolkit.widgets
Crash Signature: [@ GetBorderColor] [@ nsCSSRendering::DrawCompositeSide]
You need to log in before you can comment on or make changes to this bug.