Closed Bug 1136172 Opened 7 years ago Closed 3 years ago

Categories

(Core :: Canvas: WebGL, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED INCOMPLETE
Tracking Status
firefox36 --- affected
firefox37 --- affected
firefox38 --- affected
firefox39 --- ?

People

(Reporter: milan, Unassigned)

References

()

Details

(Whiteboard: [games] gfx-noted)

Go to the URL in summary, start, choose a level.  On Windows, you get no rendering after that, as long as you're using ANGLE.  OpenGL on Windows or OS X seem to work.
During the loading of the game (so, before I had a chance to hit Start), I get an assertion:

Assertion failure: IsCacheCorrect(mColorClearValue[0], colorClearValue[0]) && IsCacheCorrect(mColorClearValue[1], colorClearValue[1]) && IsCacheCorrect(mColorClearValue[2], colorClearValue[2]) && IsCacheCorrect(mColorClearValue[3], colorClearValue[3]), at c:\Users\msreckovic\Repos\mozilla-central\dom\canvas\WebGLContextUtils.cpp:1107

#01: mozilla::WebGLContext::ForceClearFramebufferWithDefaultValues (c:\users\msreckovic\repos\mozilla-central\dom\canvas\webglcontext.cpp:1322)
#02: mozilla::WebGLFramebuffer::CheckAndInitializeAttachments (c:\users\msreckovic\repos\mozilla-central\dom\canvas\webglframebuffer.cpp:897)
#03: mozilla::WebGLContext::Clear (c:\users\msreckovic\repos\mozilla-central\dom\canvas\webglcontextframebufferoperations.cpp:33)
#04: mozilla::dom::WebGLRenderingContextBinding::clear (c:\users\msreckovic\repos\mozilla-central\obj-i686-pc-mingw32\dom\bindings\webglrenderingcontextbinding.cpp:8865)
#05: mozilla::dom::GenericBindingMethod (c:\users\msreckovic\repos\mozilla-central\dom\bindings\bindingutils.cpp:2522)
#06: js::CallJSNative (c:\users\msreckovic\repos\mozilla-central\js\src\jscntxtinlines.h:226)
#07: js::Invoke (c:\users\msreckovic\repos\mozilla-central\js\src\vm\interpreter.cpp:498)
#08: Interpret (c:\users\msreckovic\repos\mozilla-central\js\src\vm\interpreter.cpp:2558)
#09: js::RunScript (c:\users\msreckovic\repos\mozilla-central\js\src\vm\interpreter.cpp:448)
#10: js::Invoke (c:\users\msreckovic\repos\mozilla-central\js\src\vm\interpreter.cpp:517)
#11: js::Invoke (c:\users\msreckovic\repos\mozilla-central\js\src\vm\interpreter.cpp:554)
#12: InvokeFromAsmJS (c:\users\msreckovic\repos\mozilla-central\js\src\asmjs\asmjsmodule.cpp:562)
#13: InvokeFromAsmJS_Ignore (c:\users\msreckovic\repos\mozilla-central\js\src\asmjs\asmjsmodule.cpp:577)
#14: ??? (???:???)
I'll take a look, but this sounds really spurious.
You mean the assert? Yeah, that is a red herring, in a way, it seems to be handled by your half-float patches.  Getting past that assert, with the half float patches applied, I still get just the black screen.
Testing on Win 8.1 64bit, MSI GeForce GTX 980:

I suspect that the issues with StrategyGame and xibalba are different. This is because in current Nightly (tested on 64bit version, e10s disabled, try-d3d11 enabled as per default), StrategyGame works for me, but xibalba does not, on my system xibalba shows a black screen for a few seconds at startup, but after that, it shows up correctly for a long period of time.

With StrategyGame, I'm seeing the following so far to work:
  - FF Nightly 64bit 39.0a1 (2015-02-26). try-d3d11 can be enabled or disabled, and e10s can be enabled or disabled.
  - FF Nightly 32bit 39.0a1 (2015-02-26) works as well with try-d3d11 in either state and e10s in either state.

The following render a black screen during the game level:
  - FF Dev Edition 32bit 37.0a2 (2015-02-23) with both try-d3d11 enabled or disabled, e10s disabled.
  - FF Beta 37.0 as well, with both try-d3d11 enabled or disabled.
  - and FF Stable 36.0 renders black as well, with both try-d3d11 enabled or disabled.
Oh, it is this commit from two days ago that fixes the rendering issue for me: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=65e87c0b6aef&tochange=110d66c1fd6e . But this seems to be on the contrary to what Milan reported in comment 3?
Based on comment 5, I tried to test in nightly.  The issue is now resolved in nightly.  Still happens in release, beta, and dev.
Whiteboard: [games]
Jeff, is the fix easy to uplift? Milan, can you reconfirm and verify whether it works in Nightly for you as well now?
Yes, it works for me in the nightly.  Jeff and I miscommunicated on what I was testing when I was testing for comment 3.
Whiteboard: [games] → [games] gfx-noted

Looks like there are audio-api issues now.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.