Status

--
blocker
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: alex, Assigned: hyatt)

Tracking

({crash, smoketest})

Trunk
crash, smoketest

Firefox Tracking Flags

(Not tracked)

Details

(URL)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6+)
Gecko/20011205
BuildID:    2001120504

Mozilla just died.

Reproducible: Didn't try
Steps to Reproduce:
1. I wish I knew. I just clicked on a link, and it died.

Actual Results:  Browser crash.

Expected Results:  No crash :).

Talkback ID: TB72718E.

I also had another crash (TB72757Y) about a minute later, but I'm not sure if
that's related.
CC: stephend@netscape.com, for talkback retrieval, please (TB72718E). Stephen,
please also retrieve Talkback TB72757Y as well -- and, if they don't match, I'll
file an additional bug for the second talkback.
Keywords: crash
Added URL testcase:
http://www.bestwebbuys.com/books/cgi-bin/buy.cgi?bs=onebookstreet&i=0226493636&p1=0226493636

That kills Mozilla every time for me (2001120504 on Win2k). Additional talkbacks
for this crasher: TB73211Q and TB73273Q.

Comment 3

17 years ago
Seen on linux too, 2001120508, TB 74646G
i didn't have any trouble in todays smoketests on win98, but I crashed all over 
the place on linux and a few times on macos9.  The pages I crashed on are also 
in jrgms loadtime test and as such the test was unable to complete for linux.  
making this a blocker for that reason.

commercial builds tested:
windows 2001-12-05-06-trunk (okay...passed loadtime test)
linux 2001-12-05-06-trunk (crashes...failed to complete loadtime test)
mac 2001-12-05-04-trunk (fewer crashes...passed loadtime test)
Severity: critical → blocker
Keywords: smoketest
OS: Windows 2000 → All
i was seeing this on cnn.com and netscape.com today with OSX. the crash was in
the paint code.
Hardware: PC → All
Note that hyatt turned btek orange after his checkin.

is this a dupe of 113622?
Assignee: asa → hyatt

Comment 7

17 years ago
2001120508/linux talkbacks:
TB78388W
TB78349Y
TB78169E
TB74646G

(Assignee)

Comment 9

17 years ago
Fix is just to add this to nsStyleStruct.h.  nsStyleBorder's default constructor:

nsStyleBorder() :mBorderColors(nsnull) {}

Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
I see a checkin to nsStyleStruct.cpp as well ... 

Comment 11

17 years ago
David, please include the bug # in your checkins comment next time.
linux respin 2001-12-05-12-trunk works fine...no more crashes...loadtime test 
completed and memory test (TestGtkEmbed) is cranking away

verified fixed
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Keywords: testcase
You need to log in before you can comment on or make changes to this bug.