[Camera][Lockscreen] Image cannot be rotated in a preview, when accessing from camera lockscreen with passcode enabled

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: dharris, Assigned: dmarcos)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(1 attachment)

Description:
(Expand upon the Summary - but not a copy of the Summary!)

Prerequisites: Have a passcode set on the device

Repro Steps:
1) Update a Flame to 20150224010314
2) Press power button twisce to access lockscreen
3) Swipe the toggle to the left to access camera
4) Take a picture
5) Preview picture
6) Rotate image to landscape


Actual:
The rotation animation occurs, but the image is not rotated. Also the animation will not happen again until the user goes our of preview and back in.


Expected:
Image can be rotated to different orientations freely

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 10/10
See attached: Logcat, Video - http://youtu.be/RwFVChOIYqc
Descirption for comment 0: 

While the user has a passcode lock set on their device and they take a picture from the lockscreen, they are unable to rotate the image to view it in landscape view. The rotation animation will occur but only 1 time per access of camera preview.

This issue DOES occur on Flame 2.2

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150224002637
Gaia: 8e98fe665f3821d10d4d982cbb14cbe5b94d0be5
Gecko: 2b70d9d62799
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
_____________________________________________________________________________________________

This issue does NOT occur on Flame 2.1

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150224002520
Gaia: 86af0ca427adad12c3109124f31bef2fd9614e47
Gecko: a275f2c05ca6
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI for component owner for nomination decision and assignment, it's a regression.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
I tried the same scenario on flame 2.2 with 1Gb memory. The issue does NOT occur. The image can be rotated in a preview.

Gaia-Rev        ca64f2fe145909f31af266b1730874051ba76c78
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16804008c29f
Build-ID        20150224162516
Version         37.0
Device-Name     flame
FW-Release      4.4.2

If the passcode is disabled, the image can be rotated on 319mb and 1Gb.
Hi Arthur,
this might need your help to dispatch to right owner.
Flags: needinfo?(gchang) → needinfo?(arthur.chen)
Flags: needinfo?(arthur.chen) → needinfo?(dmarcos)

Comment 4

4 years ago
I am unable to reproduce this on Master with passcode enabled or disabled (haven't tried 2.2 yet)
I can reproduce this in latest 2.2 I think this happens with 319MB memory device, and if you have your flame set to 512 or more, then might not be reproducible.  Since it's a regression, I think it's worth blocking.
blocking-b2g: --- → 2.2?

Comment 6

4 years ago
Diego: Could you please check this on 2.2?

Thanks
Hema
Assignee: nobody → dmarcos
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 7

4 years ago
Does this reproduce on a phone a production phone with 256 or 512MB of memory?
Flags: needinfo?(dmarcos) → needinfo?(npark)
hmm, this is no longer reproducible in 319MB either in builds 2.2 and 3.0. Derek, can you still repro this?  If not, I think we can close this bug.

Version tested:

2.2:
Gaia-Rev        c8136ef4094fc5509551ab7b1d5f6141491f00ef
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/12139abae350
Build-ID        20150320002502
Version         37.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150320.033941
FW-Date         Fri Mar 20 03:39:52 EDT 2015
Bootloader      L1TC000118D0

3.0:
Gaia-Rev        c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/cf1060d8ce9f
Build-ID        20150319010201
Version         39.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150319.072503
FW-Date         Thu Mar 19 07:25:15 EDT 2015
Bootloader      L1TC000118D0
Flags: needinfo?(npark) → needinfo?(dharris)
This no longer occurring on Flame 3.0 or Flame 2.2

The picture preview will rotate to landscape with a passcode enabled

Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150320010204
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: 4d2d97b3ba34
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150320002502
Gaia: c8136ef4094fc5509551ab7b1d5f6141491f00ef
Gecko: 12139abae350
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(dharris)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
I'm not sure this issue is entirely gone, just an extremely low repro rate. I saw this ONCE today (and then 0 times out of 40 or 50 attempts to repro).

This occurred the same as the steps in comment 0

Device: Flame 3.0 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150325010206
Gaia: aebfbd998041e960cea0468533c0b5041b504850
Gecko: cc0950b7a369
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
You need to log in before you can comment on or make changes to this bug.