Closed Bug 1136311 Opened 6 years ago Closed 6 years ago

Tweak overscroll prefs

Categories

(Firefox OS Graveyard :: Gaia, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(firefox37 wontfix, firefox38 wontfix, firefox39 fixed, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S7 (6mar)
Tracking Status
firefox37 --- wontfix
firefox38 --- wontfix
firefox39 --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: kats, Assigned: kats)

Details

Attachments

(1 file)

Filing this bug for the tweaking of prefs as discussed at https://bugzilla.mozilla.org/show_bug.cgi?id=1066888#c31 and later comments.
Attached patch PatchSplinter Review
Current proposal by Gordon, waiting feedback from Francis and Jamie.
Attachment #8568705 - Flags: review?(botond)
Attachment #8568705 - Flags: review?(botond) → review+
https://hg.mozilla.org/mozilla-central/rev/323936539fd7
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S7 (6mar)
Comment on attachment 8568705 [details] [diff] [review]
Patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): overscroll implementation
User impact if declined: this patch "loosens" the overscroll a little bit to make it more playful and bouncy, as per UX request. they wanted this change for a while but it was waiting on bug 1042103 to get fixed first.
Testing completed: on master for a couple of days now, haven't heard of anybody complaining. Might want to wait a few more days just in case.
Risk to taking this patch (and alternatives if risky): low-risk pref change
String or UUID changes made by this patch: none
Attachment #8568705 - Flags: approval-mozilla-b2g37?
njpark, can you have your eyes on this landing, in-case you see anything funny and also make sure to run your sanity on the build once this lands ?

I am approving this now, but as is really a nice-to-have and not a blocker, we'll backout depending on if we have worse fallouts.
Flags: needinfo?(npark)
Attachment #8568705 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Checked in on 2.2 today, on almost all types of scroll behavior, and it looks good, and it now stretches as well as the master build. :)
Flags: needinfo?(npark)
You need to log in before you can comment on or make changes to this bug.