"Error: t is null" warnings in console when data ingestion tasks have not completed yet

RESOLVED DUPLICATE of bug 1184157

Status

P3
normal
RESOLVED DUPLICATE of bug 1184157
4 years ago
a year ago

People

(Reporter: mailme.rakeshg, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8568714 [details]
Screenshot from 2015-02-25 01:17:46.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150125221831

Steps to reproduce:

setting up treeherder service and treeherder ui



Actual results:

In local treeherder service , sorting joblist gives a warning "Error: t is null
h.property/"



Expected results:

Error occurs in https://github.com/dewgeek/treeherder-ui/blob/master/webapp/app/js/models/resultsets_store.js#L866 with sort, I guess this is problem with jobList object type returned from backend api.

Comment 1

4 years ago
I've seen this too - thank you for filing :-)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
Summary: sorting jobList gives warning → Sorting jobList gives "Error: t is null" warnings in console
(Reporter)

Comment 2

4 years ago
@edmorley,

This error is because of incomplete celery task (user manually stops celery task runner during setup).
So, this error can be ignored, as it won't repeat in production server.

Comment 3

4 years ago
Yeah sounds likely. We should still make the "we haven't loaded any data yet" case not produce errors, but it's lower priority.
Priority: P1 → P3
Summary: Sorting jobList gives "Error: t is null" warnings in console → "Error: t is null" warnings in console when data ingestion tasks have not completed yet

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1184157
You need to log in before you can comment on or make changes to this bug.