[RTL][Usage] The the blue Value Selector triangles are not mirrored in Cost Control

VERIFIED DUPLICATE of bug 1151177

Status

Firefox OS
Gaia::Cost Control
P2
normal
VERIFIED DUPLICATE of bug 1151177
3 years ago
3 years ago

People

(Reporter: DerekH, Assigned: kgrandon)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(3 attachments)

Created attachment 8568745 [details]
Blue Triangles Screenshot

Description:
There are two value selectors in the usage apps settings that are not properly mirrored to the left side of the box


Repro Steps:
1) Update a Flame to 20150224010314
2) Open Usage App> Continue through Usage App FTE
3) Tap on settings (Gear icon in upper right)
4) Observe Value Selectors


Actual:
The two blue value selector triangles at the bottom of this page are not mirrored


Expected:
Blue value selector triangles are mirrored properly, like the first one is.

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 10/10
See attached: Screenshot
This issue DOES occur on Flame 2.2

The two blue value selector triangles at the bottom of this page are not mirrored

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150224002637
Gaia: 8e98fe665f3821d10d4d982cbb14cbe5b94d0be5
Gecko: 2b70d9d62799
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
Priority: -- → P2

Comment 2

3 years ago
When at FTE of Usage app, the triangle icons of value selector buttons are not left-aligned and not mirrored.

Comment 3

3 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15468/
Flags: in-moztrap+
Parul: can you please confirm if this still occurs? I can't get my sim to work in Africa on the Flame anymore.
Seems like this bug got through our nets until now. Let's just see if it still happens. thanks!
Flags: needinfo?(pmathur)
Created attachment 8587783 [details]
1136339-usage-app-FTE-settings-value-selectors-RTL.png

Yes, this is still happening. 
1. There are two value selectors in the Usage app's Settings that are not properly mirrored to the left side of the box. 
2. There are two value selectors in the Usage app's FTE that are not properly mirrored to the left side of the box.  
(See screenshots attached.)

Test Environment
Gaia-Rev        9226ac0d3d9d33b0400f8f69ec4bdf8f545a414b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d496224fd7ed
Build-ID        20150402162500
Version         37.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150402.194342
FW-Date         Thu Apr  2 19:43:53 EDT 2015
Bootloader      L1TC000118D0
Flags: needinfo?(pmathur) → needinfo?(lebedel.delphine)
Thanks Parul. It seems these are 2 different bugs. Can you please file a bug for the 2nd FTE issue, and nominate as well? I'll be away most of today so can not get to this now.

Triage: Nominating in order to ensure consistency of carats use across entire UI
blocking-b2g: --- → 2.2?
Flags: needinfo?(lebedel.delphine) → needinfo?(pmathur)
1151177 [RTL][Usage] The blue Value Selector triangles are not mirrored in Cost Control FTE

Created the bug and nominated it for blocking-b2g: 2.2?
Flags: needinfo?(pmathur)
Really a polish issue but since we are shipping RTL for the first time in 2.2 and having this inconsistency will not look good on the feature, blocking on it. Anticipating, the fix should be low risk. If otherwise, will reconsider landing on 2.2
blocking-b2g: 2.2? → 2.2+

Comment 9

3 years ago
Hi Marina,
Could you please help to check this issue? Thanks!
Flags: needinfo?(marina.rodrigueziglesias)
See Also: → bug 1151177
Hi Josh, 
This bug is not a Usage app bug. The selectors are implemented using the gaia-select component (shared/elements/gaia-select), for these reason they are not properly mirrored.

Sorry and best regards
Flags: needinfo?(marina.rodrigueziglesias)

Comment 11

3 years ago
Hi Kevin, Hi Etienne,
Could you please help to check the problem? Thank you!
Flags: needinfo?(kgrandon)

Updated

3 years ago
Flags: needinfo?(etienne)
(Assignee)

Comment 12

3 years ago
This will be fixed by bug 1151177.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Depends on: 1151177
Flags: needinfo?(kgrandon)
Flags: needinfo?(etienne)
(Assignee)

Comment 13

3 years ago
Fixed via 1151177, so marking as a duplicate.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151177
Created attachment 8637757 [details]
Verify1_v2.2.png

This issue is verified pass on latest Flame v2.2/master and N5 v2.2/master by the same STR in comment 0, Blue value selector triangles are mirrored and left-aligned in settings view.

See attachment:Verify1_v2.2.png.
Reproducing rate:0/10

Device: Flame v2.2 build (Pass)
Build ID               20150722162505
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a73051740290
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150722.195353
Firmware Date          Wed Jul 22 19:54:05 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master build (Pass)
Build ID               20150722160203
Gaia Revision          f04fdbfa1943dddeab8ecd1299a76ab56e590d00
Gaia Date              2015-07-22 18:44:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8650fe82f1cd
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150722.194012
Firmware Date          Wed Jul 22 19:40:25 EDT 2015
Bootloader             L1TC000118D0

Device: N5 v2.2 build (Pass)
Build ID               20150722002505
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a73051740290
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150722.040945
Firmware Date          Wed Jul 22 04:10:05 EDT 2015
Bootloader             HHZ12f

Device: N5 master build (Pass)
Build ID               20150722160203
Gaia Revision          f04fdbfa1943dddeab8ecd1299a76ab56e590d00
Gaia Date              2015-07-22 18:44:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8650fe82f1cd
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150722.192830
Firmware Date          Wed Jul 22 19:28:49 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
status-b2g-v2.2: affected → verified
status-b2g-master: affected → verified
You need to log in before you can comment on or make changes to this bug.