Google Translate Shows Wrong Japanese IME Input

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: rodrigozeh, Unassigned, NeedInfo)

Tracking

({inputmethod})

Trunk
x86
All
inputmethod
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150223103044

Steps to reproduce:

You need to have Windows Japanese IME enabled.

1. Go to: https://translate.google.com/#ja/en/
2. Switch your keyboard to Japanese IME Hiragana input
3. Press keyboard keys "N" then "A".


Expected result: 



Actual results:

"nあ"


Expected results:

"な" 

It works for Chrome 40 and IE 11.

I tried to find a regression range, but I could reproduce the bug all the way back to Nightly 32, when I gave up.

Comment 1

4 years ago
Confirmed
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: inputmethod
Version: 39 Branch → Trunk

Comment 2

4 years ago
With ATOK 2015.
Word in " " is displayed as already entered words.

Press keyboard keys "N" then "A".
"n"な

Press keyboard keys "A" then "A".
"あ"ああ

So, the problem is first input is unexpectedly sent as entered word.

Comment 3

4 years ago
Just now, Google has been fixed the problem by themselves.

@Rodze, Could you test again please?
Flags: needinfo?(rodrigozeh)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

4 years ago
Yes, it appears fixed.

Thanks.
Flags: needinfo?(rodrigozeh)

Comment 5

4 years ago
The problem happens again on Linux and Windows 8.1 with recent Nightly build.
IE 11 doesn't have this problem.

Comment 6

4 years ago
This bug confirmed firefox nightly on Windows8.1 and Windows7.
It occured Microsoft Office IME 2010 and Google Janapanese Input.

Build identifier: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0

Google Chrome canary v43.0.2321.0 is working fine.

thank you.

Updated

4 years ago
Status: RESOLVED → REOPENED
OS: Windows 7 → All
Resolution: WORKSFORME → ---
FYI.
Today's test result.
                                                                                         Firefox 36.0 on Win     SeaMonkey 2.32 on Win
    https://www.google.co.jp/#q=Google+Translate               Good                          Good 
    https://translate.google.co.jp/                                            Bad                            Bad
    https://translate.google.com/                                             Bad                            Bad

Comment 8

4 years ago
Hi.

Build identifier: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Built from https://hg.mozilla.org/mozilla-central/rev/98820360ab66

Now, this bug is not reproduced.
Can you confirm?

Updated

3 years ago
Component: Untriaged → Translation
Not a bug of the Firefox translation feature.
Component: Translation → Untriaged

Comment 10

3 years ago
I cannot reproduce anymore on Nightly46.0a1.
Hello, we are cleaning up items that are marked as untriaged, I need to find a component for this. Do you have any suggestions that would help. It appears that this issue has been resolved for most of you. I would request you to close this issue as resolved if you are not encountering this problem. Please confirm.
Thanks."
Flags: needinfo?(rodrigozeh)

Updated

3 years ago
Flags: needinfo?(alice0775)

Comment 12

3 years ago
I cannot reproduce the problem on the following build anymore.

https://hg.mozilla.org/mozilla-central/rev/9d6ffc7a08b6b47056eefe1e652710a3849adbf7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0 ID:20160106030225

https://hg.mozilla.org/releases/mozilla-aurora/rev/7e1284abc4733ef0372cd96671cfaac3227e2214
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0 ID:20160106004003

https://hg.mozilla.org/releases/mozilla-beta/rev/9ebad515bc39afdea1e656bf15218a0511a5d1e2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0 ID:20160104162232

And also, on the bad build.
https://hg.mozilla.org/releases/mozilla-release/rev/5a41909266e5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150806001005
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Flags: needinfo?(alice0775)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.