[Settings] - Internet Sharing Hotspot name can overlap 'Name' field when too long

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: arthurcc)

Tracking

({polish, regression})

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description:
If you write a long name, 16+ characters, the 'Name' label will be overlapped. 


Repro Steps:
1) Update a Flame to 20150224010314
2) Launch Settings app
3) Select Internet Sharing > Hotspot Settings > and enter a long name
4) Select 'ok' to return to the previous page

Actual:
overlapping text

Expected:
no overlapping text

Environmental Variables:
Device: Flame Master (KK - Nightly - Full Flash - 319mem)
Build ID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0


Repro frequency: 100%
See attached: screenshot
(Reporter)

Comment 1

4 years ago
This issue also occurs in 2.2 

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150224002637
Gaia: 8e98fe665f3821d10d4d982cbb14cbe5b94d0be5
Gecko: 2b70d9d62799
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

----------------------------------------------------------------------------------------------------

This issue does NOT reproduce in 2.1 or 2.0

Actual Results: The long name becomes truncated to fit within the alloted space

Device: Flame 2.1 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150223001204
Gaia: 88c44f2243a5ca1683587aca9faf29023974b96c
Gecko: efd5205ec813
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150223000222
Gaia: 366aaa19ac474dc58b79d62a91cff41756ae9dfe
Gecko: 611444d72a92
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Flagging UX for input for blocking nomination, low visibility but it is a regression. Flagging for at least polish.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(firefoxos-ux-bugzilla)
Keywords: polish

Comment 3

4 years ago
I believe we block on all regressions. Adding a +.
blocking-b2g: --- → 2.2+
Flags: needinfo?(firefoxos-ux-bugzilla)

Updated

4 years ago
Assignee: nobody → arthur.chen
Status: NEW → ASSIGNED
Comment on attachment 8574512 [details] [review]
[gaia] crh0716:1136427 > mozilla-b2g:master

EJ, would you mind take a look at the patch? Thanks.
Attachment #8574512 - Flags: review?(ejchen)
Comment on attachment 8574512 [details] [review]
[gaia] crh0716:1136427 > mozilla-b2g:master

I am glad we made this trick before, r++++

Thanks Arthur :)
Attachment #8574512 - Flags: review?(ejchen) → review+
Thanks, EJ!

master: 7484dfafaf9f2588fbdaa6f7fa6201378dcda626
Comment on attachment 8574512 [details] [review]
[gaia] crh0716:1136427 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: Bad user experience
[Testing completed]: Testing on the device 
[Risk to taking this patch] (and alternatives if risky): Low, only style changes
[String changes made]: None
Attachment #8574512 - Flags: approval-gaia-v2.2?
Attachment #8574512 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Please resolve bugs when landing on master.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(arthur.chen)
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S8 (20mar)
I forgot to change the status...
Flags: needinfo?(arthur.chen)
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: The name now gets truncated before it would overlap with the 'Name' label.

Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150312010235
Gaia: 0c4e8b0b330757e261b031b7e7f326ef419c9808
Gecko: 5334d2bead3e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (Full Flash) (319 MB)
BuildID: 20150312002501
Gaia: 572d60e0a440ee4af50bc6b6adad8876eadbdb4d
Gecko: 244e6ba3c20e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.