[Lockscreen] Text is partially cut off on music widget

RESOLVED DUPLICATE of bug 1124305

Status

defect
RESOLVED DUPLICATE of bug 1124305
4 years ago
4 years ago

People

(Reporter: ychung, Assigned: gweng)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(8 attachments, 4 obsolete attachments)

(Reporter)

Description

4 years ago
Posted image Widget.png
Description:
Whent the music app controller appears on the lockscreen or notification tray, Arabic text on the song info is not completely shown. It is cut off horizontally at the bottom.

Pre-requisite:  Have at least 1 song on the device with the artist or song title in Arabic or Unknown.

Repro Steps:
1) Update a Flame to 20150224010314.
2) Set the device language in Arabic under Settings > Language.
3) Open Music app.
4) Play a song with Arabic song title or artist name.
5) Bring the lock screen by pressing the power button twice, or pull down the notification tray.
6) Observe the Arabic text on the music widget.

Actual:
Arabic text is cut off horizontally.

Expected:
Arabic text is displayed completely.

Environmental Variables:
Device: Flame 3.0  (KK, 319mb, full flash)
Build ID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 5/5
See attached: screenshot
(Reporter)

Comment 1

4 years ago
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150224002637
Gaia: 8e98fe665f3821d10d4d982cbb14cbe5b94d0be5
Gecko: 2b70d9d62799
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

4 years ago
(In reply to Yeojin Chung [:YeojinC] from comment #1)
> Device: Flame 2.2 (KK, 319mb, full flash)
> Build ID: 20150224002637
> Gaia: 8e98fe665f3821d10d4d982cbb14cbe5b94d0be5
> Gecko: 2b70d9d62799
> Gonk: e7c90613521145db090dd24147afd5ceb5703190
> Version: 37.0 (2.2)
> Firmware Version: v18D-1
> User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

This issue reproduces on Flame 2.2 as well.

Result: The Arabic text is cut off horizontally on the music widget.
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
The problem here is not obvious to me from the screen shot. Long artist/title names will be truncated eventually. 

Is the bug that the string is not being truncated in the correct location? That appears to be the case in this example comparing the widget in the mirrored English locale, where we've lost the beginning of the song title instead of the end of the artist name.
Flags: needinfo?(ychung)
(Reporter)

Comment 4

4 years ago
The bug is not about truncation. When you look at the screenshot from Comment 0, the Arabic letters that are vertically long, such as "ن", are cut off at the bottom. Instead of a single curved line, it appears to be broken into two lines with the bottom part missing.
Flags: needinfo?(ychung)
Flagging Lizie who can give input on how severe this is. From what I understand, it's ugly, but the word does not loose its sense. Waiting for confirmation
Flags: needinfo?(alizee.aubertin)

Comment 6

4 years ago
Hello,
This is indeed a problem. If I can give you a better idea by comparing it to the latin alphabet, it's a bit like if the letter "y" appeared as a "v" because the lower part of the letter was cut off. So it's still legible but it looks pretty bad.
Thanks Yeojin and Lizie, the problem is clear now. In fact with the image in comment #3 you can see this is happening with English too where we lose part of the tail on the 'gg' in the song title. So this doesn't appear to be RTL specific but instead we just need to give more vertical space for all locales.
No longer blocks: music-rtl
blocking-b2g: --- → 2.2?
Flags: needinfo?(alizee.aubertin)
Summary: [RTL][Music] Arabic text is cut off horizontally on widget → [Music] Text is partially cut off on music widget

Comment 8

4 years ago
Jacqueline/Jim: Could we adjust the height of the song info in lockscreen/notification tray so characters don't get cut off towards the bottom. 

Looks like this is not a Arabic specific issue but happening for other languages too. It may be illegible for some of the languages if part of the char is not seen. 

Thanks
Hema
Flags: needinfo?(squibblyflabbetydoo)
Flags: needinfo?(jsavory)
This isn't really a music bug (anymore); it might make more sense for the Lockscreen folks to take a look at this, since they've changed the visuals several times since I last worked on this code (I'm pretty sure this wasn't an issue in my version).
Flags: needinfo?(squibblyflabbetydoo)
Moving the component to lockscreen, so it's on the right team's radar. 

Thanks
Hema
Component: Gaia::Music → Gaia::System::Lockscreen

Comment 11

4 years ago
Triage: blocking. But can UI provide the spec on the height of the title? Also we need a separate bug for the notification.
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(jsavory) → needinfo?(jsavory)

Updated

4 years ago
Assignee: nobody → gweng

Comment 12

4 years ago
Hi Rob, can you help to provide the spec? thanks.
Flags: needinfo?(jsavory) → needinfo?(rmacdonald)

Updated

4 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 13

4 years ago
Sending to Hung for visual on lock screen.
Flags: needinfo?(rmacdonald) → needinfo?(hnguyen)

Updated

4 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 14

4 years ago
Deferring to Amy as she is the own of lock screen. 

Looking at the screen, we probably just need a slight height increase to optimize the text field.
Flags: needinfo?(hnguyen) → needinfo?(amlee)
Hi, 

I flashed to the latest master and the text does not appear cut off. If you look at comment 3, it shows it being cut off in English as well. 

I suggest referencing the style in the latest master to fix this issue. Thanks
Flags: needinfo?(amlee)

Comment 16

4 years ago
qawanted to see if the problem is still there in master and 2.2, thanks
Keywords: qawanted
This issue is still reproducible on latest 3.0 and 2.2. It seems that the utility tray exhibits this issue more severely than on the lockscreen though. See screenshot on 3.0 in English.

Tested on:
Device: Flame 3.0 Master
BuildID: 20150324010202
Gaia: efebbafd12fc42ddcd378948b683a51106517660
Gecko: 840cfd5bc971
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2
BuildID: 20150324002504
Gaia: 014d38f7ad3912b8b33cb08ce7535a5dc5aced59
Gecko: 7a9f2a248e57
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)

Comment 18

4 years ago
Hi Amy, there's still problem on master so we can't refer to master to fix it.

And the original problem is for Arabic, so even if the English looks good, Arabic may still having an issue. Can you just provide a quick spec (both lockscreen and Utility tray)that's also considering the Arabic case? Thanks.

This bug is for fixing lockscreen, we need a separate bug for the Utility tray.
Flags: needinfo?(amlee)
Hi, 

I can't reproduce this issue on my flame device. 

Tested on:

Build ID               20150325083046
Gaia Revision          72d176ce52c12c7fa949df2a354edf79703caf89
Gaia Date              2015-03-17 00:01:23
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/db0409de517a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  40
Firmware Date          Tue Oct 21 15:59:42 CST 2014
Bootloader             L1TC10011880

Since I don't have an Arabic named audio file it's very hard to test but I had mocked up an example of Arabic on the same line as English and there is plenty of room below for the text to not be cut off. This is not a visual design issue, this looks like a code issue that is causing the text to be cut off. 

See attached visual reference
Flags: needinfo?(amlee)
Posted image utilitytray-3.0 (obsolete) —
I'm confused. From the latest master Gaia + Gecko the text in English on LockScreen and UtilityTray are both fine: no cutting, no hidden descenders (see the 'g' in the attachment). The UtilityTray is more obvious: the attachment by QA had been cut a lot, but from my screenshot there is no cutting.

----
Flame:
Build ID               20150325160204
Gaia Revision          b1cb8041b7014af9c455d0730c3bde8e14006c6c
Gaia Date              2015-03-26 00:36:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f40ee067d081
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  65
Firmware Date          Mon Dec 15 18:51:29 CST 2014
Bootloader             L1TC000118D0
Posted image lockscreen-v3.0.png (obsolete) —
Posted image ar-lockscreen-3.0.png (obsolete) —
With Arabic title it's good, too.
Posted image ar-utilitytray-3.0.png (obsolete) —

Comment 24

4 years ago
Can QA verify it's working fine with the build in comment 19 and 20 ? Both engineering and UI report the issue does not exist anymore.
Keywords: qawanted
Today someone reminded if I flashed from PVT the build may not correctly set as 1.5 device pixel ratio. So if this is the root cause that we couldn't reproduce it we may need to have a discussion about how to solve this.
I have filed bug 1148241 to cover the utility tray portion of this bug. Also changing bug title to separate from 1148241. We will work on the QAwanted request tomorrow.
Summary: [Music] Text is partially cut off on music widget → [Lockscreen] Text is partially cut off on music widget
(In reply to howie [:howie] from comment #24)
> Can QA verify it's working fine with the build in comment 19 and 20 ? Both
> engineering and UI report the issue does not exist anymore.

As my testing at comment 17 showed, for English on lockscreen it doesn't seem to possess this issue, and it was not mentioned anywhere in the bug that lockscreen ever had this issue (in English). Looking at the original bug, I think we should focus on Arabic characters on lockscreen.

This issue reproduces on the builds used in comment 19 and comment 20. See screenshot. I did notice a difference in our screenshots that are different than engineer's - ours has a hyphen in there that separates artist and title of the song. Perhaps the engineer can try have a shorter song name so both title and artist can be displayed. Or it could be like comment 25 mentioned, there's a discrepancy in flashing/build, though I think it's unlikely since I'm using the same builds as them.

Tested on:
Device: Flame 3.0 Master (nightly user, 319MB, KK)
BuildID: 20150325083046
Gaia: aebfbd998041e960cea0468533c0b5041b504850
Gecko: db0409de517a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 3.0 Master (nightly user, 319MB, KK)
BuildID: 20150325160204
Gaia: 508b8d48fb5ecf08bf0e5b4fef42bc48b770e7f2
Gecko: f40ee067d081
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Posted image v2.2.png
OK I re-tested it: the bug occurs on v2.2 no matter the text comes with hyphen or not; but on v3.0 it looks there are no cutting (or it's too tiny so I can't discover it). Maybe UX could re-check it again on v2.2 and v3.0 and then we could have a clear spec. Although I also wonder if this is a regression if the bug really occurs as what I found, although from the comments above it occurs both on v2.2 and v3.0.
Attachment #8583536 - Attachment is obsolete: true
Attachment #8583537 - Attachment is obsolete: true
Attachment #8583542 - Attachment is obsolete: true
Attachment #8583543 - Attachment is obsolete: true
Posted image v3.0.png
NI Howie to let him know the latest status.
Flags: needinfo?(hochang)

Comment 31

4 years ago
Hi Greg, thanks. Let's move this forward by adjust the style and fix the issue from our side first. If the screen looks good after your adjustment, we land the patch. Then UI to add what we adjusted into the spec later.
Flags: needinfo?(hochang) → needinfo?(gweng)
I strongly oppose to do this without detailed spec (to 'rem') from UX. We have had several troubles that even with such spec, due to the unclear parts in the document, we took so long while to let UX grant the UI review flag, with countless NI and tiny modifications. What I care is not the spec document, but the painful experience from the past.
Flags: needinfo?(gweng)
And I may need to mention we need another bug for the widget on UtilityTray.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124305
I found the necessary setup to reproduce this bug(Bug 1124305 comment 18), might be the font files so you need to flash the whole image. And uplifting bug 1124305 should fix this.
You need to log in before you can comment on or make changes to this bug.