Closed Bug 1136503 Opened 6 years ago Closed 6 years ago

[RTL][Browser] Scroll bar is on the wrong side.

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:backlog, b2g-v2.2 affected, b2g-master affected)

RESOLVED DUPLICATE of bug 1119057
tracking-b2g backlog
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: mikehenrty, Assigned: tedders1)

References

Details

(Whiteboard: [systemsfe])

+++ This bug was initially created as a clone of Bug #1119057 +++

Looks like bug 1119057 didn't entire take care of this issue, so I'm filing this bug as a followup. See https://bugzilla.mozilla.org/show_bug.cgi?id=1119057#c37

Description:
The scroll bar is located on the right when a webpage is displayed.
   
Repro Steps:
1) Update a Flame device to BuildID: 20150107010216.
2) Open Browser app, and navigate to a webpage that can be scrolled.
3) Scroll down the page.
  
Actual:
Scroll bar is located on the right.
  
Expected: 
Scroll bar is located on the left.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150107010216
Gaia: 69ac77cfa938fae2763ac426a80ca6e5feb6ad25
Gecko: 33781a3a5201
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: screenshot
Ted, can you take a look here?
Flags: needinfo?(tclancy)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15483/
Flags: in-moztrap+
Assignee: nobody → tclancy
Flags: needinfo?(tclancy)
Status: NEW → ASSIGNED
From what I understand, this behavior is consistent to what we currently have in the desktop browser. This being the case, we won't block on a fix here since it is already consistent with what user's expect on the web.
blocking-b2g: 2.2+ → backlog
blocking-b2g: backlog → ---
Hi Lancy,
Could you please check whether the Scroll bar is located on the left in 2.5
Flags: needinfo?(yulan.zhu)
Hi Josh,
Per comment 37 ~ comment 40 in bug 1119057, the location of the scroll bar in website depends which language the website is using, maybe we can close this issue as Wontfix or Invalid, do you agree with me?
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(yulan.zhu) → needinfo?(jocheng)
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Sorry for the error.
Status: REOPENED → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 6 years ago6 years ago
Flags: needinfo?(jocheng)
Resolution: --- → DUPLICATE
Duplicate of bug: 1119057
Let's dup this to bug 1119057
You need to log in before you can comment on or make changes to this bug.