If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Default to incremental build with mach

RESOLVED DUPLICATE of bug 1136543

Status

()

Core
mach
RESOLVED DUPLICATE of bug 1136543
3 years ago
3 years ago

People

(Reporter: kennycoc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150125222008

Steps to reproduce:

1. cd mozilla-central
2. hg pull -u
3. mach build


Actual results:

mach built firefox (as expected) taking over an hour to finish building


Expected results:

Mach compared the times the files were last opened, and compared that with the time it started the last build and determined what actually needs to be rebuilt.
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1136543
You need to log in before you can comment on or make changes to this bug.