mouse wheel scroll doesn't honor system settings

RESOLVED DUPLICATE of bug 1136177

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1136177
3 years ago
3 years ago

People

(Reporter: Aetf, Unassigned)

Tracking

39 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150224030228

Steps to reproduce:

1. Ensure system settings about mouse wheel scroll are set to scroll one line.
2. Open a website which is longer than one page
3. Use mouse wheel to scroll


Actual results:

One page scrolled each time


Expected results:

One line scrolled each time
(Reporter)

Comment 1

3 years ago
According to wiki[1], for Firefox 17 or later, "On Windows, the scroll unit is by line or page with mouse wheel. That depends on the system settings."

Tried on multiple sites and got the same result so this is not related to any specific sites. Also checked with safe mode and in about:config all mousewheel.* entries are in their default values.

Not exactly sure but if I remember correctly, I can get expected results using Firefox 38.

[1] https://wiki.mozilla.org/Gecko:Mouse_Wheel_Scrolling#Mozilla_17_.28Firefox_17.29_or_later
(Reporter)

Updated

3 years ago
OS: Windows NT → Windows 10
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1136177
You need to log in before you can comment on or make changes to this bug.