Firefox Nightly is stuck at "loading" of any app hosted in marketplace.firefox.com or searching them

RESOLVED FIXED in 2015-03-03

Status

Marketplace
Consumer Pages
P1
blocker
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Sohan Roy, Assigned: ngoke)

Tracking

Avenir
2015-03-03
x86
Windows 7
Points:
---

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8568979 [details]
Screen Shot 2015-02-25 at 11.48.09.png

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150224030228

Steps to reproduce:

Opened any app by clicking on the link
examples:
https://marketplace.firefox.com/app/box?src=desktop-promo
https://marketplace.firefox.com/app/play-piano?src=featured-app

By the way it happens with "any" page of marketplace.firefox.com
Also when searching for any app


Actual results:

The app page only shows "loading"
The search results do not come, only the spinning wheel


Expected results:

The app page with details should have loaded and shown
Also same for the search results
(Reporter)

Comment 1

3 years ago
N.B. It asked me version but I could not find out how to find the version of marketplace.firefox.com
I browsed it through firefox nightly for windows.
(Reporter)

Comment 2

3 years ago
Created attachment 8568984 [details]
Screen Shot 2015-02-25 at 11.45.52.png
(Reporter)

Updated

3 years ago
Version: 2.0 → Avenir
(Reporter)

Updated

3 years ago
OS: All → Windows 7
Hardware: All → x86
(Reporter)

Updated

3 years ago
Severity: normal → critical
Priority: -- → P1
(Reporter)

Updated

3 years ago
Component: General → Consumer Pages
(Reporter)

Updated

3 years ago
Severity: critical → blocker
(Assignee)

Updated

3 years ago
Assignee: nobody → kngo
(Assignee)

Comment 3

3 years ago
"'groupCollapsed' in window.console" wasn't working.

May have to bump other projects as well.

https://github.com/mozilla/fireplace/commit/3e82c622ee97f123e647558b59d2f7b6c8ae7bbe
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2015-03-03
(Assignee)

Comment 4

3 years ago
https://github.com/mozilla/marketplace-core-modules/commit/87ac2a9161e46a819b4e946f3bccc3c2767ef384

Comment 5

3 years ago
Verified as fixed on MP-prod, MP-dev and MP-stage.
Postfix screencast: http://screencast.com/t/dLrMwgmI
Closing bug.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

3 years ago
(In reply to ValentinaP from comment #5)
> Verified as fixed on MP-prod, MP-dev and MP-stage.
> Postfix screencast: http://screencast.com/t/dLrMwgmI
> Closing bug.

Still the searches are indefinitely loading
(Reporter)

Updated

3 years ago
Flags: needinfo?(valentina.peleskei)
(Assignee)

Comment 7

3 years ago
Valentina, are you using Nightly?

I had fixed it on my local environment, just confirmed it's still broken on servers. Relooking.
Status: VERIFIED → REOPENED
Ever confirmed: true
Flags: needinfo?(valentina.peleskei)
Resolution: FIXED → ---
(Assignee)

Comment 8

3 years ago
A more aggressive fix

https://github.com/mozilla/marketplace-core-modules/commit/e81e4d768650ab3c088eaabbe35eb357e31e07c6
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Comment 9

3 years ago
(In reply to Kevin Ngo [:ngoke] from comment #7)
> Valentina, are you using Nightly?
> 
> I had fixed it on my local environment, just confirmed it's still broken on
> servers. Relooking.

I've made the verification and the screencast on FF39(Win 7). The "Loading..." appeared for last than a second, or not appeared at all(as it can be seen in the above screencast) even before this last fix. What is the intended behavior? The "Loading..." should not appear at all? Thanks!
Flags: needinfo?(kngo)
(Assignee)

Comment 10

3 years ago
Valentina, the issue was that many pages would not load at all in Nightly (it should be reproducible on prod). If you check the web console, you'll see something like console.log[e] is not a function.

STR:

1. Go to /new on Nightly.

Expected:

Page loads

Actual:

Spinner forever
Flags: needinfo?(kngo)
(Reporter)

Comment 11

3 years ago
(In reply to ValentinaP from comment #9)
> (In reply to Kevin Ngo [:ngoke] from comment #7)
> > Valentina, are you using Nightly?
> > 
> > I had fixed it on my local environment, just confirmed it's still broken on
> > servers. Relooking.
> 
> I've made the verification and the screencast on FF39(Win 7). The
> "Loading..." appeared for last than a second, or not appeared at all(as it
> can be seen in the above screencast) even before this last fix. What is the
> intended behavior? The "Loading..." should not appear at all? Thanks!


Its still spinning forever, and loading forever

Comment 12

3 years ago
We have tested the scenarios from comment 0 and comment 10 on dev stage and production (Win7, FF39) but we couldn't reproduce it. The only issue we observed was that there was a short loading time when opening for example the "New" page (the loading was under a second - which we thought is expected, on another refresh the page was displayed instantly Screencast: http://screencast.com/t/SENJLfME4SHY) Also the same behavior was observed on an app detail page, there was a short loading time before the content was displayed (again a very short period of time, a few ms at best. Also this looks as expected: http://screencast.com/t/xrFgIHBdpS8)

Sohan can you still reproduce this issue? If yes can you please give us more details about localization (language, region set for marketplace)
Flags: needinfo?(roysohan)
(Reporter)

Comment 13

3 years ago
I wonder how come you get the good builds and everyone is stuck on bad , defective builds.

Steps to reproduce: Click on any app on the homepage, ex Etsy, PCsync, Photography, anything, only Box loads magically that I cannot figure out, search for anything for typing any terms on search box
Click on new, popular, etc, the spinner loads forever

Actual results: Spinning spinner of death
Expected: results should be expected, like the app and its details and search results

Plz give me some way to fix
Locale is English, region is India
Marketplace has gone nuts(In reply to Madalin Cotetiu from comment #12)
> We have tested the scenarios from comment 0 and comment 10 on dev stage and
> production (Win7, FF39) but we couldn't reproduce it. The only issue we
> observed was that there was a short loading time when opening for example
> the "New" page (the loading was under a second - which we thought is
> expected, on another refresh the page was displayed instantly Screencast:
> http://screencast.com/t/SENJLfME4SHY) Also the same behavior was observed on
> an app detail page, there was a short loading time before the content was
> displayed (again a very short period of time, a few ms at best. Also this
> looks as expected: http://screencast.com/t/xrFgIHBdpS8)
> 
> Sohan can you still reproduce this issue? If yes can you please give us more
> details about localization (language, region set for marketplace)
Flags: needinfo?(roysohan)
(Reporter)

Updated

3 years ago
Resolution: FIXED → WORKSFORME
(Reporter)

Updated

3 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 14

3 years ago
Sohan,

The fix is still on dev and will be pushed live tomorrow. After tomorrow, your problem should be addressed.

Sorry for the inconvenience and thanks for your patience.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

3 years ago
Sohan,

Yeah, sorry I forgot to mention. We do a weekly push schedule. As Krupa mentioned, the next push will be tomorrow on Tuesday. It is fixed, but the fix is not yet live. Thank you so much for reporting this issue!
You need to log in before you can comment on or make changes to this bug.