[Stingray] expose isVisible and focus API for activities

RESOLVED FIXED

Status

Firefox OS
Gaia::TV::System
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: sungchiu, Assigned: sungchiu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
1. isVisible API: Determine whether this UI is visible or not, and return z-index.
2. focus API: Focus the default elementin this UI.
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1136624
(Assignee)

Updated

3 years ago
Assignee: nobody → suchiu
(Assignee)

Comment 2

3 years ago
We should move these APIs from action menu to activities.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Created attachment 8572524 [details] [review]
[gaia] sean2449:Bug_1136623 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8572524 - Flags: review?(im)
Comment on attachment 8572524 [details] [review]
[gaia] sean2449:Bug_1136623 > mozilla-b2g:master

Looks good to me.
Attachment #8572524 - Flags: review?(im) → review+
merged to master:
https://github.com/mozilla-b2g/gaia/commit/c89c8b71d168025483810977ce92c7020f285c1f

gaia try is all green:
https://treeherder.mozilla.org/#/jobs?repo=gaia-try&revision=de20ab70e9f1
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.