You're taken back to the contact panel even if you delete a contact from the The "Call Information" page

RESOLVED DUPLICATE of bug 1135044

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1135044
3 years ago
3 years ago

People

(Reporter: julienw, Unassigned)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
STR:
1. have an item in the call log with a phone number without a contact.
2. long press, choose "call information"
3. choose "create new contact"
4. add a name, press save

=> KO1. We're back at the "call information" panel, but we still have the phone number as header, and the 2 buttons "add to existing contact" and "create new contact".

5. Press back
=> OK. the entry has correctly changed.

6. long press, choose "call information"
=> Same KO1 than previously seen.

7. Force kill the dialer application, start it again, open the call log.
8. long press on the item, choose "call information"
9. press "Contact Details", edit the contact, change the name, save it, press back

=> KO2: the header has not changed.

10. press "Contact Details", edit the contact, delete the contact.

=> KO3: we're not back at the "call log" panel, but back at the "contact" panel.

11. enter the call log panel again.

=> KO4: the panel is not updated.

12. press the back button.

=> The entry has been updated, but "unknown" should be displayed below the phone number, but it's not. KO5

qawanted for branch checks.
See Also: → bug 1136664
* KO1 is handled in bug 1135044.
* KO2 will probably be fixed with bug 1135044. Is that right, Gabriele? 
* KO3 sounds like a new issue, let's track it here. I renamed the bug accordingly.
* KO4 will likely be fixed in bug 1135044.
* KO5 sounds like a new issue too, I opened bug 1136664 to check it.
Summary: [Dialer] The "Call Information" page is not updated when the contact changes + several other wrong behaviors → You're taken back to the contact panel even if you delete a contact from the The "Call Information" page
@Gabriele: see comment 1.

QA wanted still wanted to check KO3 only.
Flags: needinfo?(gsvelto)
Yes, KO3 is definitely new to me, the other ones are as you suggest.
Flags: needinfo?(gsvelto)
QA Contact: bzumwalt
Issue DOES reproduce on Flame 2.1, 2.2, and 3.0

KO3 as described in comment 0 does reproduce. When user deletes contact from contact edit page while coming from call information screen, the user is returned to the contacts tab instead of the call log tab.

Device: Flame 2.1
Build ID: 20150225001618
Gaia: 86af0ca427adad12c3109124f31bef2fd9614e47
Gecko: a275f2c05ca6
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2
Build ID: 20150225002505
Gaia: ca64f2fe145909f31af266b1730874051ba76c78
Gecko: 16804008c29f
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0
Build ID: 20150225010244
Gaia: f6bfd854fe4746f21bc006eac145365e85f98808
Gecko: 0a8b3b67715a
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Unable to test on Flame 2.0 as Call Information screen function did not exist


NOTE: Contact details button does not appear at step 9 in comment 0 unless user has at least 2 contacts (including newly created one from STR.) I do not know if this is a new bug or a side-effect of one of the existing bugs mentioned in comment 1. Advice on this would be appreciated.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Clearing the nomination: Edge case which is not a regression.

NI myself to check the end of comment 4.
blocking-b2g: 2.2? → ---
Flags: needinfo?(jlorenzo)
(In reply to Brogan Zumwalt [:BroganZ] from comment #4)
> NOTE: Contact details button does not appear at step 9 in comment 0 unless
> user has at least 2 contacts (including newly created one from STR.) I do
> not know if this is a new bug or a side-effect of one of the existing bugs
> mentioned in comment 1. Advice on this would be appreciated.

I checked the behavior and this explains why we didn't see the same thing in bug 1135044 comment 0 and bug comment 3. Before shooting the video, I tried multiple times on my phone and then I removed all the call log entries and all my contacts. Thanks for noticing this difference. I'll put you comment in bug 1135044.
Flags: needinfo?(jlorenzo)
This should have been fixed as part of bug 1135044 so closing as a duplicate. Johan I'm not sure if this is worth verifying again since I've also handled the delete contact case in that bug so I'll leave it to you if you want to verify it or not.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Flags: needinfo?(jlorenzo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1135044
verifyme to check if bug 1135044 has fixed KO3.
Flags: needinfo?(jlorenzo)
Keywords: verifyme
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #8)
> verifyme to check if bug 1135044 has fixed KO3.

Hi Johan,
The problem of KO3 is verified fail on latest build of Flame 2.2/3.0. Could you help with it? Thanks!
Actual result: After deleting the contact, device will not go back to "call log" panel, but back to "contact" panel.
STR:
1. Have an item in the call log with a phone number but without a contact.
2. Long press, choose "call information"
3. Choose "create new contact"
4. Add a name, tap "Done"
5. Tap back icon
6. Long press, choose "call information"
7. Tap "Contact Details", edit the contact, delete the contact.
See attachment: Verify_video.MP4 & logcat_1558.txt

Device: Flame 2.2 (Fail)
Build ID               20150323162503
Gaia Revision          e54c4ed1cc188f70ddf1156534d364005dc45490
Gaia Date              2015-03-23 19:09:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7ba1778d237b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.200543
Firmware Date          Mon Mar 23 20:05:54 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (Fail)
Build ID               20150323160205
Gaia Revision          8eac260ee81a8aca05770d18c5736536d44ee7a7
Gaia Date              2015-03-23 02:41:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/bc85c479668a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.193421
Firmware Date          Mon Mar 23 19:34:34 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
Created attachment 8582253 [details]
logcat_1558.txt
Created attachment 8582254 [details]
Verify_video.MP4
You need to log in before you can comment on or make changes to this bug.