31.5 - Matching address shows red when multiple matches are available

RESOLVED DUPLICATE of bug 1042561

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 1042561
3 years ago
3 years ago

People

(Reporter: Charles, Unassigned)

Tracking

31 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150222232811

Steps to reproduce:

Updated to the new version 31.5, which does indeed fix most of the addressing bugs that have been plaguing users

Tested, and discovered a reproducible test case where the resulting matched address still shows as red:

1. Start composing an email

2. Start entering the first few characters of an email address that will result in multiple matches



Actual results:

3. When you enter the very first character, a list of matching addresses is presented, with the currently selected entry in black

4. Enter another character, it selects a different entry to match, and it turns red

5. Keep typing characters and note that the entry remains red unless you type at least one additional character AFTER there is only one result match showing


Expected results:

All matching entries should show in black, all the time.

Comment 1

3 years ago
I see the same behavior in THUNDERBIRD_36_0b1_BUILD2

Comment 2

3 years ago
This is seen in end-user release:  

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Thunderbird/31.5.0

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1042561
You need to log in before you can comment on or make changes to this bug.