Removing a touch event listener from a window doesn't remove the force-dtc flag on the layer

RESOLVED FIXED in Firefox 39, Firefox OS v2.2

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

(Blocks: 1 bug)

Trunk
mozilla39
All
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox37 wontfix, firefox38 wontfix, firefox39 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

While checking Greg's patch on bug 1130016 I noticed that even though his code removed the touchstart listener, the force-dtc flag still persisted on the layer. This happens because the layer at [1] is reused across paints, and we only set the override flag but we never clear it. This is an error in the refactoring patch I landed for bug 1131840.

[1] http://mxr.mozilla.org/mozilla-central/source/layout/base/nsDisplayList.cpp?rev=96d7198bec0a#4171
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Comment on attachment 8569318 [details] [diff] [review]
Patch

Review of attachment 8569318 [details] [diff] [review]:
-----------------------------------------------------------------

Tricky!
Attachment #8569318 - Flags: review?(botond) → review+
https://hg.mozilla.org/mozilla-central/rev/6e8707d9962d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Comment on attachment 8569318 [details] [diff] [review]
Patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): regression from bug 1131840
User impact if declined: in some cases the APZ will perform less well than it should, because we weren't properly tracking removal of touch listeners from the DOM. Honestly the impact of this is low unless we also land bug 1116579 but the risk is also quite low so requesting uplift anyway.
Testing completed: locally
Risk to taking this patch (and alternatives if risky): very low risk, just fixes a refactoring error.
String or UUID changes made by this patch: none
Attachment #8569318 - Flags: approval-mozilla-b2g37?

Updated

4 years ago
Attachment #8569318 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2caa69cc467c
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
status-firefox37: --- → wontfix
status-firefox38: --- → wontfix
You need to log in before you can comment on or make changes to this bug.