Ad fails to load in debug mode, causes assert about non-overrideable binding being overridden

RESOLVED WORKSFORME

Status

Firefox Graveyard
Shumway
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: till, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

3 years ago
For all I know this might be gone with the new bindings. Besides perhaps something else going wrong here, we could always encounter SWFs that try to do invalid things like this. Meaning that we must not assert, but somehow gracefully handle this case.
I think it's just a flaw in the ABC file. Perhaps we just need to remove the assertion.
(Reporter)

Comment 2

3 years ago
(In reply to Michael Bebenita [:mbx] from comment #1)
> I think it's just a flaw in the ABC file. Perhaps we just need to remove the
> assertion.

That's exactly what I mean: it's an assert caused by content, and we must not have any of those.
(Reporter)

Updated

3 years ago
Blocks: 1037568
(Reporter)

Comment 3

3 years ago
Should get fixed by the AVM2 overhaul, marking for later verification.
Assignee: mbebenita → nobody
Blocks: 1037580
No longer blocks: 1037568
(Reporter)

Comment 4

3 years ago
(In reply to Till Schneidereit [:till] from comment #3)
> Should get fixed by the AVM2 overhaul, marking for later verification.

Yup.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.