Marketplace app always shows notification/message 'You have been signed out' on startup

VERIFIED FIXED in 2015-06-02

Status

Marketplace
Consumer Pages
P2
minor
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Avenir
2015-06-02
ARM
Gonk (Firefox OS)
Points:
---

Details

(Whiteboard: [spark][ktlo])

B2G 2.2 20150225002505 on Flame (v188 base image)

The Marketplace app always shows the notification 'You have been signed out' on startup, even after clearing the cookies from :debug, terminating and relaunching the app. Submit the logs with ID 10588.

I have never signed in on this device since factory resetting it.

Updated

3 years ago
Assignee: nobody → krupa.mozbugs
Keywords: qawanted
I am seeing this on the Spark device while testing. It is running a nightly build.
Whiteboard: [spark]

Updated

3 years ago
Duplicate of this bug: 1158732
Regarding Comment 1, I was not signed into Marketplace when I saw this. The build in Comment 1 was freshly flashed on the Z3.

Comment 4

3 years ago
I can reproduce this behavior on a fresh install


STR:
1. Flash the latest eng build of 2.2 on your flame.
2. Launch marketplace prod

observed behavior:
Upon launching marketplace prod, we show them the message "You are signed out". 

We check if the user is signed in to the phone when marketplace is launched. We should be showing the "You are signed out" message only if the user has previously signed in.


04-28 22:10:14.973 I/Marketplace( 1104): Content JS LOG: [yulelog] Handled post message from https://marketplace.firefox.com: {"type":"fxa-watch","email":""} 
04-28 22:10:14.973 I/Marketplace( 1104):     at log (app://marketplace.firefox.com/main.js:4:8)
04-28 22:10:14.973 I/Marketplace( 1104): Content JS LOG: [yulelog] Registering FxA callbacks 
04-28 22:10:14.973 I/Marketplace( 1104):     at log (app://marketplace.firefox.com/main.js:4:8)
04-28 22:10:14.983 I/Marketplace( 1104): Content JS LOG: [yulelog] Handled post message from https://marketplace.firefox.com: "loaded" 
04-28 22:10:14.983 I/Marketplace( 1104):     at log (app://marketplace.firefox.com/main.js:4:8)
04-28 22:10:14.983 I/Marketplace( 1104): Content JS LOG: [yulelog] Preparing to send activities ... 
04-28 22:10:14.983 I/Marketplace( 1104):     at log (app://marketplace.firefox.com/main.js:4:8)
04-28 22:10:14.983 I/Marketplace( 1104): Content JS LOG: [yulelog] Sending activities: [] 
04-28 22:10:14.983 I/Marketplace( 1104):     at log (app://marketplace.firefox.com/main.js:4:8)
04-28 22:10:14.983 I/Marketplace( 1104): Content JS LOG: [yulelog] fxa-logout 
04-28 22:10:14.983 I/Marketplace( 1104):     at log (app://marketplace.firefox.com/main.js:4:8)
04-28 22:10:14.983 I/Marketplace( 1104): Content JS LOG: [yulelog] postMessaging to https://marketplace.firefox.com: {"type":"fxa-logout"} 
04-28 22:10:14.983 I/Marketplace( 1104):     at log (app://marketplace.firefox.com/main.js:4:8)
04-28 22:10:15.363 I/Marketplace( 1104): Content JS LOG: [installer] Checking for app update succeeded (downloadaapplied) for https://marketplace.firefox.com/packaged.webapp 
04-28 22:10:15.363 I/Marketplace( 1104):     at u/< (https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1430244831750:4:15661)
04-28 22:10:15.363 I/Marketplace( 1104): Content JS LOG: [installer] Checking for app update succeeded (downloadaapplied) for https://marketplace.firefox.com/packaged.webapp 
04-28 22:10:15.363 I/Marketplace( 1104):     at u/< (https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1430244831750:4:15661)
04-28 22:10:15.363 I/Marketplace( 1104): Content JS LOG: [update_banner] No update found. 
04-28 22:10:15.363 I/Marketplace( 1104):     at u/< (https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1430244831750:4:15661)
04-28 22:10:19.303 V/WLAN_PSA(  210): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
Priority: -- → P1

Updated

3 years ago
Keywords: qawanted

Updated

3 years ago
Target Milestone: --- → 2015-05-05

Comment 5

3 years ago
This bug is in master too, on Flame for since the new Marketplace if I remember correctly.

Build ID               20150516010201
Build Type             user
Gaia Revision          84d77c1f3cbe06b91d4a5acac02a6c829e9a7488
Gaia Date              2015-05-15 20:20:56
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f1bb9cfd7661
Gecko Version          41.0a1
Device ID              flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150212.043653
Firmware Date          Thu Feb 12 04:37:04 EST 2015
Bootloader             L1TC000118D0
Assignee: krupa.mozbugs → nobody
Severity: normal → minor
Priority: P1 → --
Target Milestone: 2015-05-05 → ---

Updated

3 years ago
Priority: -- → P2

Updated

3 years ago
Whiteboard: [spark] → [spark][ktlo]
https://github.com/mozilla/marketplace-core-modules/commit/e6d161262568ce29331184493d84d3662ee12983
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2015-06-02

Comment 7

3 years ago
Verified as fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.