Update celery libs

RESOLVED FIXED in 2015-06-16

Status

P2
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: robhudson, Assigned: robhudson)

Tracking

Avenir
2015-06-16
x86
Mac OS X
Points:
---

Details

(Whiteboard: [ktlo][qa-])

(Assignee)

Description

4 years ago
We're starting to fall behind on celery and dependent libs. Let's upgrade them. Some notable changes I've seen mentioned in the docs:
* The default serialization has been changed to json (away from pickle) for security.
* The 'celery' project my no longer need 'django-celery'. Django support is shipped by default.

Also review what the recommended version of RabbitMQ is and upgrade to that.
Priority: -- → P2
We're going to need to upgrade djcelery at least for Django1.8, according to the deprecation warnings in the logs.
(Assignee)

Comment 3

3 years ago
https://github.com/mozilla/zamboni/commit/57d310c
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2015-06-16

Comment 4

3 years ago
Can you please add some STRs to this bug or mark it as [qa-] ?
(Assignee)

Comment 5

3 years ago
We've been testing and filing new bugs so I'll mark this [qa-].
Whiteboard: [ktlo] → [ktlo][qa-]
You need to log in before you can comment on or make changes to this bug.