Closed Bug 1136864 Opened 5 years ago Closed 5 years ago

[Contacts] When adding/editting a contact, no scroll bar is present

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S7 (6mar)
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: onelson, Assigned: hola)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

Description:
When creating a new contact or editting an old one, the user will observe that no scrollbar will be present on the UI. May be of note, that within this field, if the user were to cancel out every edittable field (tap the 'x' to close all inputs) then they may receive a UI that does fit within the length of the screen, thus requiring no scroll bar.


Repro Steps:
1) Update a Flame to 20150225010244
2) Open the Contacts app.
3) Tap the '+' to add a new contact.
4) Pan the screen down; watch for scroll bar.

Actual:
No scroll bar is present on the screen when scrolling.

Expected:
Scroll bar appears pans vertically on a page.

--------------------------------
Environmental Variables:
Device: Flame 3.0
Build ID: 20150225010244
Gaia: f6bfd854fe4746f21bc006eac145365e85f98808
Gecko: 0a8b3b67715a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2
BuildID: 20150225002505
Gaia: ca64f2fe145909f31af266b1730874051ba76c78
Gecko: 16804008c29f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

==================================================
Issue DOES NOT REPRO on 2.1 for flame devices
Results: Scroll bar appears pans vertically on a page.

Device: Flame 2.1
BuildID: 20150225001618
Gaia: 86af0ca427adad12c3109124f31bef2fd9614e47
Gecko: a275f2c05ca6
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
--------------------------------------------------

Repro frequency: 5/5
See attached: 
video
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
This is likely due to RTL work.

[Blocking Requested - why for this release]: Visible regression.
blocking-b2g: --- → 2.2?
requesting a window.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141125015936
Gaia: b7b30dc8b781cdc699a1c9723a0554e8d2ff5c51
Gecko: 7bc4b4ee5b8e
Version: 36.0a1 (2.2 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141125022733
Gaia: 93e9acf37605e9d75142a89f82385341b2c8aedd
Gecko: 1673e5aadc59
Version: 36.0a1 (2.2 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: b7b30dc8b781cdc699a1c9723a0554e8d2ff5c51
Gecko: 1673e5aadc59

Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: 93e9acf37605e9d75142a89f82385341b2c8aedd
Gecko: 7bc4b4ee5b8e

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/b7b30dc8b781cdc699a1c9723a0554e8d2ff5c51...93e9acf37605e9d75142a89f82385341b2c8aedd

Caused by patch for Bug 1094709.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Jose, can you take a look at this please? This looks like it could have been caused by the landing for bug 1094709.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(jmcanterafonseca)
Assignee: nobody → hola
Flags: needinfo?(jmcanterafonseca)
triage: regression
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8571356 [details] [review]
[gaia] ADLR-es:scrollbar > mozilla-b2g:master

A class that hides the scrollbar was added to the form view. Removing it shows the scrollbar as usual and the clear button also works as expected.
Attachment #8571356 - Flags: review?(jmcf)
Comment on attachment 8571356 [details] [review]
[gaia] ADLR-es:scrollbar > mozilla-b2g:master

thanks Adrian
Attachment #8571356 - Flags: review?(jmcf) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S7 (6mar)
Comment on attachment 8571356 [details] [review]
[gaia] ADLR-es:scrollbar > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1094709
[User impact] if declined: No scrollbar will be shown in form view
[Testing completed]: Manual testing (visual issue)
[Risk to taking this patch] (and alternatives if risky): Really low, just css.
[String changes made]: None
Attachment #8571356 - Flags: approval-gaia-v2.2?
Attachment #8571356 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed for the latest Nightly 3.0 and 2.2 builds.

Actual Results:  The Add/Edit contact screen has a scroll bar.
	
Environmental Variables:
Device: Flame 3.0 KK (319 MB) (Full Flash)
BuildID: 20150304010324
Gaia: 3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gecko: c5b90c003be8
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (319 MB) (Full Flash)
BuildID: 20150304002529
Gaia: 8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gecko: 2cb52b7cda5a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.