shutdownhang in nsThread::Shutdown() coming from ScopedXPCOMStartup::~ScopedXPCOMStartup()

RESOLVED WORKSFORME

Status

()

Toolkit
Startup and Profile System
--
critical
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: rstrong, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

report 710ca468-c86d-47bf-8552-604122150225.
=============================================================

I have seen several of these while looking for crashes for bug 1134620. The same crash signature also appears to happen in other parts of the code as well.
No longer depends on: 1134620

Comment 1

3 years ago
bp-710ca468-c86d-47bf-8552-604122150225
Summary: crash in shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_Wait | mozilla::ReentrantMonitor::Wait(unsigned int) | nsThread::ProcessNextEvent(bool, bool*) | NS_ProcessNextEvent(nsIThread*, bool) | nsThread::Shutdown() → shutdownhang in nsThread::Shutdown() coming from ScopedXPCOMStartup::~ScopedXPCOMStartup()

Updated

3 years ago
Duplicate of this bug: 1155076

Updated

3 years ago
Crash Signature: [@ shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_Wait | mozilla::ReentrantMonitor::Wait(unsigned int) | nsThread::ProcessNextEvent(bool, bool*) | NS_ProcessNextEvent(nsIThread*, bool) | nsThread::Shutdown()] → [@ shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_Wait | mozilla::ReentrantMonitor::Wait(unsigned int) | nsThread::ProcessNextEvent(bool, bool*) | NS_ProcessNextEvent(nsIThread*, bool) | nsThread::Shutdown()] [@ shutdownhang | Wai…

Updated

3 years ago
Crash Signature: [@ shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_Wait | mozilla::ReentrantMonitor::Wait(unsigned int) | nsThread::ProcessNextEvent(bool, bool*) | NS_ProcessNextEvent(nsIThread*, bool) | nsThread::Shutdown()] [@ shutdownhang | Wai… → [@ shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_Wait | mozilla::ReentrantMonitor::Wait(unsigned int) | nsThread::ProcessNextEvent(bool, bool*) | NS_ProcessNextEvent(nsIThread*, bool) | nsThread::Shutdown()] [@ shutdownhang | Wai…

Comment 3

2 years ago
Bug listed belongs in bug 1134620.
"Startup" is misleading in the name, the code is part of the shutdown process.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134620
There are several versions of the WaitForSingleObject bug. 

Bug 1134620 is for when it occurs in nsThread::Shutdown()

This bug occurs in ScopedXPCOMStartup::~ScopedXPCOMStartup()

Back when I filed I checked the crash reports and this is a different bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I'm marking this bug as WORKSFORME as bug crashlog signature didn't appear from a long time (over half year) in Firefox.
Status: REOPENED → RESOLVED
Last Resolved: 2 years agoa year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.