Developer Edition updates (whatsnew, firstrun, Product Page) - Design & Copy

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: ckprice, Assigned: tpalmer)

Tracking

Details

(Whiteboard: engagement-fxGrowth-2015, URL)

>>Project/Request Title:
Updates to Developer Edition landing page - Design & Copy

>>Project Overview:
Design & Copy updates to the Developer Edition landing page which will highlight WebVR.

This will launch with the Firefox Growth Campaign on May 12th.

Wiki: https://wiki.mozilla.org/Firefox_Growth_Campaign_2015

>> Creative Help Needed:
Copy:    Yes 
Design:  Yes 
Video:   No 
Other:  No

>>Creative Specs:
Full spec TBD

>>CTA and Design:
Full spec TBD

>>Creative Due Date:
2015-03-26

>>Launch Date:
2015-05-12

>>Mozilla Goal:
Org Support

>>Mozilla Creative Collective:
No

>>Points of Contact:
Not provided
Whiteboard: engagement-fxGrowth-2015
The brief has been delivered in bug1132097comment5.

There will be two items to highlight: Performance Tool and WebVR

Deliverables:

- Updated product page - https://www.mozilla.org/en-US/firefox/developer/
- Updated /firstrun - https://www.mozilla.org/en-US/firefox/38.0a2/tour/

Videos will be produced by another team.
Per our meeting today, the deliverables have been extended to include a /whatsnew page. It will be a paired down clone of the /firstrun page (see brief). We may request a review from Lee for /whatsnew and some screencast thumbnails, but no other design resources will be required for any dev ed work.

We need the following assets from creative:

1. WebVR block copy
- title
- description

2. Performance tools block copy
- title
- description

3. WebVR screencast thumbnail

4. Performance Tools screencast thumbnail

5. /whatsnew title/sub title
- e.g. 'you've been updated!', with a note to users that this is what's new with Dev Ed
- should match very closely with what we're doing for release.
Summary: Updates to Developer Edition landing page - Design & Copy → Developer Edition updates (whatsnew, firstrun, Product Page) - Design & Copy
Duplicate of this bug: 1136916

Updated

4 years ago
Assignee: jbalaco → troy

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

4 years ago
Hey folks

Here is the link to copy deck with the revised subhead and two new blurbs for WebVR and Performance Tools:

https://docs.google.com/document/d/1a3OoGm0NfL7IveMoVlGLccnPAoleJx-oGEO8lVaRSIM/edit?usp=sharing

Let me know if there are any questions.

Thanks,
Troy
Copy is final approved.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Copy deck updated with the headline for /whatsnew

Also, the order of priority for features should be:

Performance Tools
WebVR

Page Inspector
Web Audio Editor
Web Console
JS Debugger
Network Monitor
Style Editor
Responsive Design View (add to /firstrun)
Web IDE
Valence
UPDATE

1. en-US: will see Performance Tools on the left, and What We Fixed on the right.
2. Non en-US: will see Performance Tools centered, and no What We Fixed at all.

Copy for the blurb can be found in bug 1159932 comment 11. Headline will read: "Check out what we fixed"

It will contain a screenshot and link to a hacks post (bug 1159932 comment 4)
/firstrun

Will be updated to highlight Performance Tools and Page Inspector at the top.

Product Page

Just adding Performance Tools.
(In reply to Cory Price [:ckprice] from comment #7)
> UPDATE
> 
> 1. en-US: will see Performance Tools on the left, and What We Fixed on the
> right.
> 2. Non en-US: will see Performance Tools centered, and no What We Fixed at
> all.
> 
> Copy for the blurb can be found in bug 1159932 comment 11. Headline will
> read: "Check out what we fixed"
> 
> It will contain a screenshot and link to a hacks post (bug 1159932 comment 4)

I think we need to tweak the copy slightly to follow the structure of headline, blurb, link. Also shortening the headline and copy a bit to match the others:

What we fixed

When we released Firefox Developer Edition, we asked for your feedback. We received tons of great ideas,  many of which have been implemented just in the last month.

See how you helped »
(In reply to Cory Price [:ckprice] from comment #8)
> /firstrun
> 
> Will be updated to highlight Performance Tools and Page Inspector at the top.
> 
> Product Page
> 
> Just adding Performance Tools.

For /firstrun, we need to determine what should be shown based on available translations. Previously, we had decided:

- If translation exists, show Performance Tools and WebVR
- If no translation, show Web IDE and Valence

Since we're replacing WebVR with Page Inspector (which is translated for all locales), what should the new logic be? Should we keep the same logic, simply replacing WebVR with Page Inspector? Or should we always show Page Inspector and only toggle Performance Tools for either Web IDE or Valence?

Also, the top two features have slightly larger screenshots that the others in the list. We will need larger screenshots for the existing features - Page Inspector, Web IDE, and Valence.

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Hi Jon,

In general, let's refer to comment 6 for what should take priority on firstrun.

/firstrun

If Performance Tools is available, the top two should be:

Performance Tools, Page Inspector

If Performance Tools is not available, the top two should be:

Page Inspector, Web Audio Editor

Product Page

Insert Performance Tools, and reorder/make sure everything in comment 6 is in.

> We will need larger screenshots for the existing features - Page Inspector, Web IDE, and Valence

Looks like we'll only need a larger screenshot for Page Inspector.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.