All users were logged out of Bugzilla on October 13th, 2018

Developer Edition updates (whatsnew, firstrun, Product Page) - Development

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: ckprice, Assigned: jpetto)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1681491] engagement-fxGrowth-2015, URL)

Development updates for the landing page set to launch with the Firefox Growth Campaign.

Wiki: https://wiki.mozilla.org/Firefox_Growth_Campaign_2015
Whiteboard: engagement-fxGrowth-2015
Whiteboard: engagement-fxGrowth-2015 → [kb=1681491] engagement-fxGrowth-2015
Updating this bug to include all dev work for Developer Edition

1. /firstrun - add two blocks
2. product page - add two blocks
3. /whatsnew (new) - clone /firstrun; update hero section with two new blocks; no UITour interaction; remove everything else below the Sync block.
Summary: Updates to Developer Edition landing page - Development → Developer Edition updates (whatsnew, firstrun, Product Page) - Development
Duplicate of this bug: 1136911
:jpetto - copy is final approved in bug 1136909 comment 4.

We don't have design for this, direction is in the design bug, as well as comment 1.

I know it's a bit vague, so let me know if you'd like to hook up.

Thanks!
Flags: needinfo?(jon)
(Assignee)

Comment 4

4 years ago
I assume the new features should be appended (prepended?) to the "All your favorite dev tools and more" section, which means we'll need links and videos for each...right?
Flags: needinfo?(jon)
(In reply to Jon Petto [:jpetto] from comment #4)
> I assume the new features should be appended (prepended?) to the "All your
> favorite dev tools and more" section, which means we'll need links and
> videos for each...right?

Your assumption is correct!

For firstrun/whatsnew the two features will take over the top two highlights https://www.mozilla.org/en-US/firefox/38.0a2/tour/
(Assignee)

Updated

4 years ago
Assignee: nobody → jon
(Assignee)

Comment 6

4 years ago
Just to clarify:

- On /firefox/developer/, the two new features will be added to the start of the "All your favorite dev tools and more" section.

- On /firefox/38.0a2/tour/, the two new features will replace the current top two highlights, which means WebIDE and Valence will no longer be on the page at all.

- On /firefox/38.0a2/whatsnew/, the page will essentially be a mirror of the firstrun page, though without a tour and without the "Features and tools" section.

Lastly, I'm assuming the logic for showing the dev whatsnew template will match that of showing the dev firstrun template - if "a2" exists in the version number, it's dev edition.

Is that all correct?
Flags: needinfo?(cprice)
Hi Jon, 

(In reply to Jon Petto [:jpetto] from comment #6)
> - On /firefox/developer/, the two new features will be added to the start of
> the "All your favorite dev tools and more" section.

http://cl.ly/image/0H1e2z0b1n1Z 

Looks good.

> - On /firefox/38.0a2/tour/, the two new features will replace the current
> top two highlights, which means WebIDE and Valence will no longer be on the
> page at all.

http://cl.ly/image/1R0h3B1T0S0z

Hmm, I see you replaced the WebIDE and Valence, but didn't add them to the lower section. There is no direction here. 

NI :ckprice to follow up with Arcadio

1) Remove two lower blocks and keep total at 6?
2) Just add another row

> - On /firefox/38.0a2/whatsnew/, the page will essentially be a mirror of the
> firstrun page, though without a tour and without the "Features and tools"
> section.

http://cl.ly/image/3l2u140P2S2l

Looks like we never got the updated headline/subhead per bug 1136909 comment 4 into the copy doc[0].

Can we take the headline from https://www-demo3.allizom.org/en-US/firefox/37.0/whatsnew/

"Hooray! Your Firefox is up to date."

And use the new /firefox/developer subhead:

"The only browser made for developers like you."

Or perhaps remove the subhead altogether?

NI troypalmer - thoughts?

> Lastly, I'm assuming the logic for showing the dev whatsnew template will
> match that of showing the dev firstrun template - if "a2" exists in the
> version number, it's dev edition.
> 
> Is that all correct?

NI :sylvestre - we're adding a whatsnew for developer edition. Does this sound like right logic to you?

[0] Copy doc: https://docs.google.com/document/d/1a3OoGm0NfL7IveMoVlGLccnPAoleJx-oGEO8lVaRSIM/edit
Flags: needinfo?(troy)
Flags: needinfo?(sledru)
Flags: needinfo?(cprice)
Flags: needinfo?(cprice)

Comment 8

4 years ago
Hey Cory

Sorry, totally missed the ask for the /what's new headline and subhead. I still think we need something there. How's this:

Your Firefox is up to date
Now get to the know the newest Developer Edition features

Also, is it worth giving an edit to the Performance Tools blurb to get it down to four lines?
Flags: needinfo?(troy)
Thanks Troy - I also missed it in the copy document.

(+ Flod to keep informed)

I'm going to meet with Arcadio tomorrow to see if we can use an existing string since this has already been exposed to localizers.
Flags: needinfo?(cprice)
We have "Your Firefox is up to date." around.

For the second, what about "Get to know the features that make it the most complete browser for building the Web."? It's already in the developer page lang file.
> > Lastly, I'm assuming the logic for showing the dev whatsnew template will
> > match that of showing the dev firstrun template - if "a2" exists in the
> > version number, it's dev edition.
> > 
> > Is that all correct?
> 
> NI :sylvestre - we're adding a whatsnew for developer edition. Does this
> sound like right logic to you?
Yes but AFAIK, this is not displayed in the user agent.
Flags: needinfo?(sledru)
(Assignee)

Comment 12

4 years ago
The "a2" part of the version is expected to be in the URL, e.g.

/firefox/38.0a2/firstrun/
(In reply to Jon Petto [:jpetto] from comment #12)
> The "a2" part of the version is expected to be in the URL, e.g.
> 
> /firefox/38.0a2/firstrun/

Just a note that the developer edition version for June 2nd isn't necessarily 38.0.

:sylvestre - do we know what dev edition version will be for June 2nd?
Flags: needinfo?(sledru)
(In reply to Cory Price [:ckprice] from comment #13)
> (In reply to Jon Petto [:jpetto] from comment #12)
> :sylvestre - do we know what dev edition version will be for June 2nd?
Should be 40!
Flags: needinfo?(sledru)
(Assignee)

Comment 15

4 years ago
Not a problem - the logic checks for a version greater than 35 with "a2" in the URL. As long as that "a2" remains, we'll be fine.
UPDATE:


# /whatsnew HEADLINE (using existing string)

Congrats! You’re up to date

No changes to subhead

# Features

**All features should be listed on /firstrun and the product page (11 total)

Here is the full list in order of priority:

Performance Tools (top left)
WebVR

Page Inspector
Web Audio Editor
Web Console
JS Debugger
Network Monitor
Style Editor
Responsive Design View (needs to be added to /firstrun)
Web IDE
Valence

PMM is okay with an unbalanced row.

:jpetto - let me know if anything is still unclear.
Flags: needinfo?(jon)
(Assignee)

Comment 17

4 years ago
Hm, what page has the string "Congrats! You're up to date"?

I see "Congrats! You’re using the latest version of Firefox." on /firefox/new/, but not the string mentioned above.

Also, a reminder that we need a video, screenshot, and link for Performance Tools and WebVR.
Flags: needinfo?(jon) → needinfo?(cprice)
Ah, it's actually in the new /whatsnew page, sorry.

https://github.com/mozilla/bedrock/commit/2566cb9a86358432c4f89ff606927317304593e4#diff-f04e7a3ba6434d3fca8bd6e7868dd051R36

And it is 'Congrats. You're up to date!' (swap punctuation). Copy doc is updated.

I've also updated bug 1136921 comment 5 with a request for update on the link/image/video.
Flags: needinfo?(cprice)
Design finalized in bug 1136909
Flags: needinfo?(jon)
(Assignee)

Comment 20

3 years ago
Just pushed an update to demo5:

/firstrun
https://www-demo5.allizom.org/en-US/firefox/40.0a2/firstrun/

/whatsnew
https://www-demo5.allizom.org/en-US/firefox/40.0a2/whatsnew/
https://www-demo5.allizom.org/fr/firefox/40.0a2/whatsnew/

/developer
https://www-demo5.allizom.org/en-US/firefox/developer/


Blockers for launch:

- Screencast link for Performance Tools (or decision that we have no screencast)

Nice to have for launch:

- Large screenshots for WebIDE & Valence (used on /whatsnew for locales without spring campaign localization). Currently using small screenshots, which isn't perfect, but is shippable.
Flags: needinfo?(jon)

Comment 21

3 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/a8f9943effa33bb3a6db9ffe201c3bb9af272822
Bug 1136912. Dev edition updates.

https://github.com/mozilla/bedrock/commit/1aacca1e9131b949da971f75e1e79d967df9e318
Merge pull request #2931 from jpetto/bug-1136912-fx-dev-edition-updates

Bug 1136912. Dev edition updates.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.