Console flooded by ServiceWorkerManager.cpp

RESOLVED DUPLICATE of bug 1144876

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1144876
3 years ago
3 years ago

People

(Reporter: mayhemer, Unassigned, Mentored)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=c++][good first bug])

(Reporter)

Description

3 years ago
Current m-c

NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file .\dom\workers\ServiceWorkerManager.cpp, line 2369
NS_ENSURE_SUCCESS(rv, false) failed with result 0x80004005: file .\netwerk\protocol\http\HttpBaseChannel.cpp, line 1952

Because ServiceWorkerManager::GetDocumentRegistration fails to find the document (mControlledDocuments.Get(aDoc) fails):

>	xul.dll!mozilla::dom::workers::ServiceWorkerManager::GetDocumentRegistration(0x05b2e000, 0x002d4e0c) Line 2380	C++
 	xul.dll!mozilla::dom::workers::ServiceWorkerManager::IsControlled(0x05b2e000, 0x002d4e7e) Line 2368	C++
 	xul.dll!nsDocShell::ShouldPrepareForIntercept(0x1ab75ac0, false, 0x002d4e7e) Line 13951	C++
 	xul.dll!mozilla::net::HttpBaseChannel::ShouldIntercept() Line 1951	C++
 	xul.dll!mozilla::net::nsHttpChannel::AsyncOpen(0x05f911f0, 0x00000000) Line 4737	C++
 	xul.dll!nsXMLHttpRequest::Send(0x00000000, {...}) Line 3016	C++


STR:
google image results, browse larger images

If this is not fatal, there shouldn't be ensures.

Comment 1

3 years ago
You're right. GetDocumentRegistration should instead return NS_OK if the hashtable lookup fails, and the callers should be sure to check for a null ServiceWorkerRegistrationInfo pointer.
Mentor: josh@joshmatthews.net
Whiteboard: [lang=c++][good first bug]

Comment 2

3 years ago
Hey Josh,
Can I work on this bug?

Comment 3

3 years ago
Go for it!

Comment 4

3 years ago
Hi Josh!
I'm totally new to this and needed help on getting started.
Can you assign this bug to me?

Comment 5

3 years ago
(In reply to Pradyot Prakash from comment #4)
> Hi Josh!
> I'm totally new to this and needed help on getting started.
> Can you assign this bug to me?

Sorry, Vaibhav has already started to work on this.

Updated

3 years ago
Duplicate of this bug: 1140270
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1144876
You need to log in before you can comment on or make changes to this bug.