Interactive Intelligence

RESOLVED FIXED in Firefox 41

Status

Firefox Graveyard
Screen Sharing Whitelist
RESOLVED FIXED
3 years ago
16 days ago

People

(Reporter: Xander Dumaine, Assigned: mreavy)

Tracking

Trunk
Firefox 41
All
Other

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
>> Vendor name
Interactive Intelligence

>> Point of contact
Xander Dumaine

>> Site URLs
mypurecloud.com, mypurecloud.com.au

>> Does the application provide users with notice and control?
http://help.mypurecloud.com/articles/purecloud-privacy-policy/

>> Have you seen and agree with the Developer Screen Sharing Submission policy?
Yes

>> Does the usage comply with the Developer Screen Sharing Submission Policy guidelines?
Yes
(Reporter)

Comment 1

3 years ago
Currently the actual apps live at https://apps.mypurecloud.com/directory/ - we'll be launching screen sharing as a feature soon (already live internally), and would like to be able to list Firefox as add-on and plugin free. We're currently using a published add-on to alter the allowed domains list, but would love to be whitelisted instead.
(Reporter)

Comment 2

3 years ago
Could I get an update on this? The app is now live, and free to use. Users can sign up for an account at http://www.inin.com/pages/signup.aspx and begin using WebRTC video chat with screen sharing.
(Reporter)

Comment 3

3 years ago
Bump.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mreavy)
(Assignee)

Comment 4

3 years ago
Sorry for the delay on this.  I've talked with Shell, and we'll resolve this bug within the week.
Flags: needinfo?(mreavy)

Comment 5

3 years ago
Hi Maire - based on our review, we can add this request to into the whitelist on nightly (currently Fx41).  Likely should put in for uplift based on timing request for their live application.

Hi Xander,
Sorry for the delay and thank you for your patience.  Your privacy policy looks good, but is hard to locate.  Could that be moved somewhere more accessible for users?
Flags: needinfo?(xander.dumaine)
Flags: needinfo?(mreavy)
(Reporter)

Comment 6

3 years ago
Created attachment 8609568 [details]
login-screen

There's a link to the privacy policy on the login screen, and another in the help menu always visible.
Flags: needinfo?(xander.dumaine)
(Reporter)

Comment 7

3 years ago
Created attachment 8609569 [details]
help-menu

There's a link to the privacy policy on the login screen, and another in the help menu always visible.
(Reporter)

Comment 8

3 years ago
Just added two screenshots of the ways to access it. These were the places legal and UX worked on for placement. It's also searchable from help. Do you think we need more than that?
(Reporter)

Updated

3 years ago
Flags: needinfo?(sescalante)
(Assignee)

Comment 9

3 years ago
Created attachment 8610576 [details] [diff] [review]
Interactive Intelligence added to screensharing whitelist
(Assignee)

Updated

3 years ago
Assignee: nobody → mreavy
Status: NEW → ASSIGNED
(Assignee)

Comment 10

3 years ago
Comment on attachment 8610576 [details] [diff] [review]
Interactive Intelligence added to screensharing whitelist

Review of attachment 8610576 [details] [diff] [review]:
-----------------------------------------------------------------

Randell, please sanity check and land this.  NOTE: We also have approval to land Bug 1151351, which I'll be updating next.  So it probably makes sense to land those two together today.  Thanks!
Attachment #8610576 - Flags: review?(rjesup)
(Assignee)

Comment 11

3 years ago
(In reply to Xander Dumaine from comment #8)
> Just added two screenshots of the ways to access it. These were the places
> legal and UX worked on for placement. It's also searchable from help. Do you
> think we need more than that?

Thanks, Xander!  This is sufficient.  If you could take a look at the patch on this bug to verify that your domain names are listed as you need them to be, that'd be helpful.  My plan is to land the patch today and then request uplift (to Fx40 and Fx39) once it reaches Nightly (Fx41) tomorrow.
Flags: needinfo?(xander.dumaine)
Flags: needinfo?(sescalante)
Flags: needinfo?(mreavy)
(Reporter)

Comment 12

3 years ago
The domains look right, but are missing the "*." prefix for wildcard subdomains.
Flags: needinfo?(xander.dumaine) → needinfo?(mreavy)
(Reporter)

Comment 13

3 years ago
That would be my fault for not including that in the original request - sorry about that.
(Assignee)

Comment 14

3 years ago
(In reply to Xander Dumaine from comment #12)
> The domains look right, but are missing the "*." prefix for wildcard subdomains.

Do you need just *.mypurecloud.com, *.mypurecloud.com.au?  Or all 4: mypurecloud.com, mypurecloud.com.au, *.mypurecloud.com, *.mypurecloud.com.au
Flags: needinfo?(mreavy) → needinfo?(xander.dumaine)
(Reporter)

Comment 15

3 years ago
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #14)

> Do you need just *.mypurecloud.com, *.mypurecloud.com.au?  Or all 4:
> mypurecloud.com, mypurecloud.com.au, *.mypurecloud.com, *.mypurecloud.com.au

I do not need the bare root domains, just *.mypurecloud.com, *.mypurecloud.com.au
Flags: needinfo?(xander.dumaine)
(Assignee)

Comment 16

3 years ago
Created attachment 8610606 [details] [diff] [review]
Interactive Intelligence added to screensharing whitelist
(Assignee)

Updated

3 years ago
Attachment #8610576 - Attachment is obsolete: true
Attachment #8610576 - Flags: review?(rjesup)
(Assignee)

Comment 17

3 years ago
Comment on attachment 8610606 [details] [diff] [review]
Interactive Intelligence added to screensharing whitelist

Review of attachment 8610606 [details] [diff] [review]:
-----------------------------------------------------------------

Randell -- This has the changes that Xander needs.  Please review and land this patch.  I'll also be updating the patch on Bug 1151351 since it was based on the older patch of this bug that I just obsoleted.  Thanks.
Attachment #8610606 - Flags: review?(rjesup)
(Reporter)

Comment 18

3 years ago
Looks good to me. Thanks!
(Assignee)

Comment 19

3 years ago
(In reply to Xander Dumaine from comment #18)
> Looks good to me. Thanks!

Cool.  We'll land it today.

Updated

3 years ago
Attachment #8610606 - Flags: review?(rjesup) → review+
https://hg.mozilla.org/mozilla-central/rev/d8b2b0ce0e52
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
(Assignee)

Comment 22

3 years ago
Comment on attachment 8610606 [details] [diff] [review]
Interactive Intelligence added to screensharing whitelist

Approval Request Comment
[Feature/regressing bug #]:screensharing whitelist 
[User impact if declined]: Interactive Intelligence will be launching screensharing very soon, and they need their domain added to our whitelist so that screensharing works for all Firefox users when they launch.
[Describe test coverage new/current, TreeHerder]: manually verified (it's a text only change)
[Risks and why]: Extremely low risk, very easily verified
[String/UUID change made/needed]: No strings
Attachment #8610606 - Flags: approval-mozilla-beta?
Attachment #8610606 - Flags: approval-mozilla-aurora?
status-firefox39: --- → affected
status-firefox40: --- → affected
Comment on attachment 8610606 [details] [diff] [review]
Interactive Intelligence added to screensharing whitelist

Low risk for the release, ok to uplift.
Attachment #8610606 - Flags: approval-mozilla-beta?
Attachment #8610606 - Flags: approval-mozilla-beta+
Attachment #8610606 - Flags: approval-mozilla-aurora?
Attachment #8610606 - Flags: approval-mozilla-aurora+

Updated

16 days ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.