Since updating to FF 36 startup time has increased dramatically and can be more than a minute.

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: smcc, Unassigned)

Tracking

36 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150222232811

Steps to reproduce:

I updated FF to version 36.


Actual results:

FF startup time increased from 10 seconds to 60+ seconds.


Expected results:

No change in start up time.
(Reporter)

Comment 1

3 years ago
I have tried uninstalling and reinstalling Firefox 36, creating a new profile and resetting FF firewall permissions in NIS, all with no effect.
A new Firefox profile doesn't help ?
The only way to proceed would be that you find the regression range (first bad build) because I can not reproduce your issue and we have no other reports.

Are you willing to install our mozregression tool to find the first bad build ?
(Reporter)

Comment 3

3 years ago
(In reply to Matthias Versen [:Matti] from comment #2)
> A new Firefox profile doesn't help ?
> The only way to proceed would be that you find the regression range (first
> bad build) because I can not reproduce your issue and we have no other
> reports.
> 
> Are you willing to install our mozregression tool to find the first bad
> build ?

Thank you, Matthias. I am perfectly happy to install the tool.

WRT no other reports, at least one other user has th same problem.  http://forums.mozillazine.org/viewtopic.php?f=38&t=2916281&p=14042723#p14042723
Please first test a nightly build: https://nightly.mozilla.org/ 
You want the 32bit one as all release builds on windows are 32bit.
(Reporter)

Comment 5

3 years ago
I have tried both 32-bit and 64-bit versions of Nightly and both open in < 6 seconds.
Can you please also try the Firefox (37) beta : https://www.mozilla.org/de/firefox/channel/
(Reporter)

Comment 7

3 years ago
FF 37 beta takes > 10 seconds to open.
Is Firevfox37 ok or slow as Firefox36 ?
"> 10 seconds" ~ "10 seconds" (comment#0)
(Reporter)

Comment 9

3 years ago
FF 36 takes up to 60 seconds to open. FF 37 is a good deal faster but slower than Nightly,which opens in 3-4 seconds.
I thought that the issue is caused by one change in the source code but it seems that it's not true.
Finding a regression with our tool is therefore probably impossible :-(
- http://mozilla.github.io/mozregression/
(Reporter)

Comment 11

3 years ago
Hello, again. After update to version 36.0.1  on 6 March Firefox startup speeded dramatically and I thought "Good. The problem has been solved". I had 2 weeks of happiness with a startup time of a few seconds.Unfortunately when I updated to version to 36.0.3 on 21 March startup deteriorated to 60 seconds. Today a further update to 36.0.4 has made no difference to the startup time. Nothing else on the PC has changed and there is no sign of malware

Please, please, please can someone help?
(Reporter)

Comment 12

3 years ago
Hello, again. After update to version 36.0.1  on 6 March Firefox startup speeded dramatically and I thought "Good. The problem has been solved". I had 2 weeks of happiness with a startup time of a few seconds.Unfortunately when I updated to version to 36.0.3 on 21 March startup deteriorated to 60 seconds. Today a further update to 36.0.4 has made no difference to the startup time. Nothing else on the PC has changed and there is no sign of malware

Please, please, please can someone help?
Hi smcc, 

Sorry for the long wait on response. Try updating to Firefox 43. Are you still having this issue?
Flags: needinfo?(stewartmccormick)
Component: Untriaged → General
Product: Firefox → Core
(Reporter)

Comment 14

3 years ago
Hello. As you are aware Firefox has gone through several re-incarnations since I first had my problem. I can't rmemember which version rectified the problem but it is now running very quickly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Updated

3 years ago
Flags: needinfo?(stewartmccormick)
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.