App menu is empty, only shows "Quit"

RESOLVED FIXED

Status

Thunderbird
OS Integration
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: receipt, Unassigned)

Tracking

Trunk
x86
Mac OS X

Thunderbird Tracking Flags

(thunderbird38 fixed, thunderbird39 fixed, thunderbird40 fixed, thunderbird41 fixed, thunderbird_esr38+ fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36

Steps to reproduce:

go to "Earlybird" menu to see version and if an update is available 

earlybird 38.0a2.en-US.mac 26 Feb 2015 
Mac Os 10.10.2


Actual results:

Normally, I go to "Earlybird" menu and there is an item called "about" where I can see EB version and eventually be prompted to update if there is an update evailable.
Now I only get the option to quit.
No way I can get info on version and, eventually, offered an update


Expected results:

Normally, I go to "Earlybird" menu and there is an item called "about" where I can see EB version and eventually be prompted to update if there is an update evailable.
Now I only get the option to quit.
No way I can get info on version and, eventually, offered an update
(Reporter)

Comment 1

2 years ago
Disabling addons (safe mode) does not solve the issue
screen shot?
anything in tools | error console?
Component: Untriaged → Mail Window Front End
Flags: needinfo?(receipt.ghezzi)
(Reporter)

Comment 3

2 years ago
Created attachment 8569888 [details]
screenshot

screenshot showing missing "about thunderbird"
Flags: needinfo?(receipt.ghezzi)
(Reporter)

Comment 4

2 years ago
Created attachment 8569891 [details]
errorconsole_part_1
(Reporter)

Comment 5

2 years ago
Created attachment 8569892 [details]
errorconsole_par_2
(Reporter)

Comment 6

2 years ago
reverting to TB beta 36.0 fixes this

Comment 7

2 years ago
I installed Earlybird 38.0a2 (2015-02-27) on an OSX Yosemite system, and could not reproduce this bug.

Comment 8

2 years ago
Last week I also saw this problem some days on Nightly builds. There were also lots of mozitest fails and OS X related backouts on TreeHerder. However it was solved somehow.

I haven't been building lastly the v38 when it was on Nightly, so I didn't see it then.
nomis101, can you be sure to test this when you test 38 beta?
(Reporter)

Comment 10

2 years ago
tried yesterday - cannot find a 38 beta - only 37.0b1 or 39.0a1 or 39.0a2 (30 March).
Tried all of them. 37.0b1 works fine, all the other don't.
They show again same problem.
Reproduced on MacMini/OsX 10.10.2 (UK version) and MacBookAir2011UK OSX 10.10.3beta

Comment 11

2 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #9)
> nomis101, can you be sure to test this when you test 38 beta?

I've tested this with 38.0b1 and it works fine for me. 
Build ID: 20150401012718. Tested on Yosemite 10.10.2.
Maybe it only occurs under certain circumstances?

Comment 12

2 years ago
Seen on latest trunk build yesterday. The menu Earlybird (or Daily or Thunderbird, or whatever) is a feature exclusive of the OS X operating system which includes menu items found on other categories in the other suppoerted operating systems. That is the reason I am changing it to OS Integration.
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → OS Integration
Ever confirmed: true
Version: 38 → Trunk

Updated

2 years ago
Summary: earlybird 38.0a2.en-US.mac 26 Feb 2015 cannot "get info" to update → App menu is empty, only shows "Quit"

Comment 13

2 years ago
I have the same issue with Thunderbird 38.0.1 on OS X 10.10.3.

I have the following suspicious message in the system log during TB startup:

12.06.15 23:38:40,519 Thunderbird[15266]: GetDYLDEntryPointWithImage(/System/Library/Frameworks/AppKit.framework/Versions/Current/AppKit,_NSCreateAppKitServicesMenu) failed.

This may be of interest because the "ServicesMenu" is normally part of the "Thunderbird" menu on OS X, the one that only shows "Quit".

Comment 14

2 years ago
This is a core issue and Bug 1151345.
(In reply to Nomis101 from comment #14)
> This is a core issue and Bug 1151345.

We'll need to take the patch for this if bug 1151345 isn't approved for Fx ESR? (it hasn't even been requested yet)
Flags: needinfo?(rkent)

Comment 16

2 years ago
Yes we'll try to get this in the next release.
status-thunderbird_esr38: --- → affected
tracking-thunderbird_esr38: --- → +
Flags: needinfo?(rkent)
Duplicate of this bug: 1174480

Comment 18

2 years ago
Patch uplifted from bug 1151345:

https://hg.mozilla.org/releases/mozilla-esr38/rev/07b9ccbfb490

(THUNDERBIRD_38_VERBRANCH)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-thunderbird38: --- → fixed
status-thunderbird39: --- → fixed
status-thunderbird40: --- → fixed
status-thunderbird41: --- → fixed
status-thunderbird_esr38: affected → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.