Scroll wheel doesn't work on Bugzilla query page

RESOLVED WONTFIX

Status

()

Core
XUL
--
major
RESOLVED WONTFIX
16 years ago
16 years ago

People

(Reporter: Waldemar Horwat, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
Future
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
If I open the Bugzilla query page, the mouse scroll wheel doesn't scroll it,
even if I explicitly focus on the page itself and hold the mouse outside any
controls.  Instead, it does weird text highlighting of the page's non-editable
text (outside any controls) and/or pops up context menus in the window's upper
left corner, regardless of where the mouse is.

Similar problems afflict the My Netscape page.

Comment 1

16 years ago
Dupe of 33732?
(Reporter)

Comment 2

16 years ago
Possibly; however, 33732 refers to a similar problem on PC's and has
Windows-specific comments.  The symptoms on the Mac are different and weirder,
including mysterious selection of background text without ever clicking the mouse.
(Reporter)

Updated

16 years ago
Depends on: 33732
(Reporter)

Updated

16 years ago
Keywords: nsbeta1

Comment 3

16 years ago
I'm having a problem where the scroll wheel will stop working in OS X. It may be
this bug, but I'm not sure since it doesn't necessarily happen on pages with
form elements (like bug 33732 does). I've even seen it happen on pages that are
displaying text documents.

The symptom is that the mouse wheel stops scrolling. The only thing I've found
that makes it work again is selecting *in the upward direction*. That usually
causes the wheel to begin functioning again.

Is this a different bug?
(Reporter)

Updated

16 years ago
Severity: normal → major

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Updated

16 years ago
Keywords: mozilla1.0, nsdogfood
(Reporter)

Comment 4

16 years ago
*** Bug 121574 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
Nav Triage:  marking nsbeta1-, need evidence of this happening on normal users
sites before working on this.
Keywords: nsbeta1 → nsbeta1-

Comment 6

16 years ago
Well, I see this on every "normal users site", any web page with forms or not.
See my comments in bug 121574 for details. The trick in comment 3 does not work
for me. Please tell if I can help with more information or simple debugging.
(Reporter)

Comment 7

16 years ago
Re: comment 5.  This bug happens on popular sites as well.  For example, this
bug occurs on my Charles Schwab account view and trading pages (can't give the
URL -- you need to have an account with Schwab with some history in it to see this).

Requesting re-triage.
Keywords: nsbeta1- → nsbeta1

Comment 8

16 years ago
We won't have time for this, ->pinkerton?
Assignee: hyatt → pinkerton
Status: ASSIGNED → NEW
(Assignee)

Comment 9

16 years ago
this is due to the existing native scrollbar in the form widgets conflicting
with the one that we use for scrollwheel. there's not much we can do about this,
especially not at this point but should magically go away when we use xbl form
controls.

i'd future it, but that would lead someone to the idea that some work will at
some point be done to fix it, which there won't because it works on osx. WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 10

16 years ago
With a Microsoft Intellimouse Optical (and driver for macos9) it seems to work
fine, but with the Kensington mouse (and newest driver) the same old problem is
there. This is Mozilla build 2002100603. The Kensington mouse works fine with
all other applications.
You need to log in before you can comment on or make changes to this bug.