Toolbox is destroyed when switching between apps

RESOLVED FIXED in Firefox 39

Status

DevTools
WebIDE
RESOLVED FIXED
3 years ago
a month ago

People

(Reporter: ochameau, Assigned: ochameau)

Tracking

unspecified
Firefox 39

Firefox Tracking Flags

(firefox39 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
This is due to the toolbox-close even handling form webide.js:
  http://mxr.mozilla.org/mozilla-central/source/browser/devtools/webide/content/webide.js#919

We end up closing the toolbox no matter which toolbox dispatched this toolbox-close event. We are racing this code when opening new toolboxes. Sometimes, we are receiving this event for the previously destroyed toolbox, *after* the new toolbox is being created. So that we end up breaking the creation of the new one.

STR are to connect to clock app, open a toolbox and then switch to main process.
It will automatically start opening the main process toolbox and fail doing it with no particular exception.

This issue may be highlighted by bug 1059308, I haven't tried to reproduce it on nightly. But the code itself looks wrong. We shouldn't _always_ close the _current_ toolbox when receiving toolbox-close. Also note that the DOM message event was useful in app manager case, it isn't in webide as we don't have nested iframes. We could just emit an event on toolbox-host of pass a listener in toolbox options.
(Assignee)

Updated

3 years ago
Attachment #8569937 - Flags: review?(jryans)
Comment on attachment 8569937 [details] [diff] [review]
patch v1

Review of attachment 8569937 [details] [diff] [review]:
-----------------------------------------------------------------

Seems reasonable.
Attachment #8569937 - Flags: review?(jryans) → review+
(Assignee)

Comment 3

3 years ago
This patch may only apply on top of bug 1059308 (which is also checkin-needed).
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/ead3ea3e566e
Assignee: nobody → poirot.alex
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
sorry had to back this out in https://treeherder.mozilla.org/#/jobs?repo=fx-team&revision=bc64e4250685 seems one of this changes caused :

https://treeherder.mozilla.org/logviewer.html#?job_id=2141984&repo=fx-team
Flags: needinfo?(poirot.alex)
(Assignee)

Comment 6

3 years ago
Was failing because of regression introduced in dependency bug 1059308.

Green try:
  https://treeherder.mozilla.org/#/jobs?repo=try&revision=cca5bb48656a
Flags: needinfo?(poirot.alex)
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/94bbcc8d45e6
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/94bbcc8d45e6
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 39

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.