MediaStream object does not function as documented

RESOLVED DUPLICATE of bug 910249

Status

()

RESOLVED DUPLICATE of bug 910249
4 years ago
4 years ago

People

(Reporter: steve, Unassigned)

Tracking

35 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36

Steps to reproduce:

Fetch a MediaStream object either by using getUserMedia() or by setting up a WebRTC connection and using getRemoteMedia()


Actual results:

A mediaStream object is received, but it is sub functional. The read-only attributes 'id' and 'ended' are absent, and the MediaStream.onended event does not fire (as per bug #1045810)



Expected results:

As documented on MDN here: https://developer.mozilla.org/en-US/docs/Web/API/MediaStream
stream.id works in Nightly now. Try http://jsfiddle.net/0vqd4bmk

ended is not yet implemented.
See Also: → bug 910249, bug 1103188
Status: UNCONFIRMED → NEW
Ever confirmed: true
ended: see bug 1045810 and bug 818812

This should be dupped to bug 910249 I think
Flags: needinfo?(jib)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jib)
Resolution: --- → DUPLICATE
Duplicate of bug: 910249
You need to log in before you can comment on or make changes to this bug.