[e10s] - all e10s tabs crash [@ mozalloc_abort(char const*) | Abort | NS_DebugBreak | mozilla::ipc::MessageChannel::DebugAbort

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: kjozwiak, Assigned: billm)

Tracking

({crash})

39 Branch
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(e10sm7+)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8569931 [details]
testcase.html

Every opened e10s tab will crash instantly when you right click and select "Save Link As..." using the attached testcase.html. When you do this without e10s enabled, you'll receive a "Download Error" prompt message indicating that an "unknown error" has occurred. We should be handling this better rather than crashing all the tabs.

Crashes:
========

* https://crash-stats.mozilla.com/report/index/973a5855-9fef-45f8-b18b-c75702150225
* https://crash-stats.mozilla.com/report/index/3c52919c-d83c-421e-a5c4-7a74c2150226

STR:
====

* open fx with e10s enabled and open several tabs (facebook, twitter etc..)
* open the attached testcase.html, right click the link and select "Save Link As.."
* you'll notice that all the opened e10s tabs crash instantly

OS's:
====

* OSX 10.10.2 x64 -> Reproduced
* Win 8.1 x64 -> Reproduced

Used the following m-c build to reproduce the issue:
* http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2015-02-26-03-02-25-mozilla-central/
(Reporter)

Updated

4 years ago
tracking-e10s: --- → ?
Assignee: nobody → wmccloskey
tracking-e10s: ? → m7+

Updated

4 years ago
Severity: normal → critical
Keywords: crash
Summary: [e10s] - [@ mozalloc_abort(char const*) | Abort | NS_DebugBreak | mozilla::ipc::MessageChannel::DebugAbort → [e10s] - all e10s tabs crash [@ mozalloc_abort(char const*) | Abort | NS_DebugBreak | mozilla::ipc::MessageChannel::DebugAbort
This doesn't crash for me on the latest Nightly.
(Reporter)

Comment 2

3 years ago
(In reply to Mike Conley (:mconley) - Needinfo me! from comment #1)
> This doesn't crash for me on the latest Nightly.

Yup, looks like it doesn't crash anymore!

* Crashing all the tabs when using the build from comment #0
** http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2015-02-26-03-02-25-mozilla-central/

* Doesn't crash anymore when using the latest build of m-c
** http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2015-05-05-03-02-06-mozilla-central/

Checked with the following OS's:

- Win 7 x86 - PASSED
- Win 8.1 x64 - PASSED
- OSX 10.10.3 x64 - PASSED
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.