Closed Bug 1137357 Opened 5 years ago Closed 5 years ago

marionette_driver 0.1 archive on pypi is missing requirements.txt file

Categories

(Testing :: Marionette, defect, blocker)

defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1124667

People

(Reporter: drno, Unassigned)

Details

When installing marionette 0.8.7 form the firefox tests archive via
  python setup.py install
I get the following error:

creating 'dist/marionette_client-0.8.7-py2.7.egg' and adding 'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing marionette_client-0.8.7-py2.7.egg
removing '/home/mozilla/venv/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg' (and everything under it)
creating /home/mozilla/venv/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg
Extracting marionette_client-0.8.7-py2.7.egg to /home/mozilla/venv/lib/python2.7/site-packages
marionette-client 0.8.7 is already the active version in easy-install.pth
Installing marionette script to /home/mozilla/venv/bin

Installed /home/mozilla/venv/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg
Processing dependencies for marionette-client==0.8.7
Searching for marionette-driver==0.1
Reading https://pypi.python.org/simple/marionette-driver/
Best match: marionette-driver 0.1.0
Downloading https://pypi.python.org/packages/source/m/marionette_driver/marionette_driver-0.1.0.tar.gz#md5=eb8335250d7fa45607ababc4fcd8caaa
Processing marionette_driver-0.1.0.tar.gz
Writing /tmp/easy_install-D4A_Dn/marionette_driver-0.1.0/setup.cfg
Running marionette_driver-0.1.0/setup.py -q bdist_egg --dist-dir /tmp/easy_install-D4A_Dn/marionette_driver-0.1.0/egg-dist-tmp-kEusth
error: [Errno 2] No such file or directory: 'requirements.txt'

Turns out if you download that marionette_driver archive and unpack it that it's setup.py is looking for a requirements.txt file which is not part of the archive. I guess someone just copy and pasted that setup.py from another package :-)
Turns out that there is actually a requirements.txt in our tree: https://dxr.mozilla.org/mozilla-central/source/testing/marionette/driver
But apparently it has not made it into the archive on pypi.
Summary: marionette_driver 0.1 has broken setup.py → marionette_driver 0.1 archive on pypi is missing requirements.txt file
Severity: normal → blocker
I fixed that earlier today but it hasn't made it into todays nightly build yet as it looks like. Is more work necessary to do as what I did in bug 1124667?
All looks fine for the tests.zip file of the latest mozilla-inbound build. You will have to wait for the next official nightly or tinderbox build on mozilla-central if you are using the tests.zip file.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124667
You need to log in before you can comment on or make changes to this bug.